1
$\begingroup$

I need to turn of 1 driver for testing as more than one driver affects the same shape key. There's a shape key getting a 1 value when it is suppose to be 0 in rest pose mode so I need to debug.

I try the clicking on the eye, only hides the graph details.
I try to click on the speaker, nothing changes.
I try >Toggle >Mute, nothing changes.

All I can do is turn disable the shape key but it doesn't help my situation.

$\endgroup$
  • 1
    $\begingroup$ Clicking the speaker icon mutes the driver - so it shouldn’t be having any effect - so my guess would be that you have something else acting on it such as keyframes. You could try actually deleting the driver or changing it to drive it at a single constant value and see what difference that makes. Check for keyframes - have you perhaps baked it to keyframes so that it still operates with the driver disabled? $\endgroup$ – Rich Sedman Nov 28 '17 at 7:44
  • $\begingroup$ @Rich Sedman I added a blend file, as a simplification of the problem. How do I mute this driver without destroying it or disabling the shape key? $\endgroup$ – Eric Huelin Nov 28 '17 at 19:13
  • $\begingroup$ Hi @Eric. It seems to be working for me - if I click the speaker icon to mute the driver and then change the Scripted Expression, nothing changes. If I then click the speaker icon to enable the driver and then change the Scripted Expression, the driven shape key value is changing. What version of Blender are you using? It appears to be working fine on 2.76. $\endgroup$ – Rich Sedman Nov 28 '17 at 21:28
  • $\begingroup$ @Rich Sedman The mute the speaker causes the driver to ignore its changed conditions. So the same question remains, how do I turn off the driver? To unpurple for lack of a better word the shape key without destroying the driver and all its settings, so I can manually change its value using the shape key slider. $\endgroup$ – Eric Huelin Nov 29 '17 at 1:15
  • $\begingroup$ @EditHuelin I understand your problem now - it's not so much disabling the driver but adjusting the value when it has been disabled. Added an answer - hope this helps. $\endgroup$ – Rich Sedman Nov 29 '17 at 8:10
2
$\begingroup$

The speaker icon in the Driver list allows the driver to be muted.

driver mute

When the driver is enabled (unmuted) it will affect the property as normal. When it is disabled (muted) it will no longer execute.

When muted it is possible to adjust the driven value manually. Keying into the driven field will override the scripted expression of the driver (eg, entering '0.45' will change the Scripted Expression to 0.45) - losing the old driver expression. However, in the case of shape keys you can drag left and right on the Value property to adjust its value and, providing the driver is 'muted', the new value will take effect.

animated muted driver


An alternative option is to use keyframes to adjust the value - since if the driver is muted the property will revert to the value of the f-curve. Note, however, that the f-curve value will only be re-applied on change of frame or if you adjust the f-curve directly.

To achieve this, simply move the mouse over the Value and press I to insert the keyframe; the colour of the property should change to yellow to indicate the keyframe.

You can now adjust the keyed value via the Graph Editor window. Select the Value channel (it should be represented by a horizontal line since it's a constant), press G to Grab, and move it up and down to adjust the value. With the driver enabled the change in the graph editor should not affect the shape key. With the driver disabled, the graph editor value should affect the shape key.

graph editor

$\endgroup$
  • $\begingroup$ Thanks for clearing that up, and I like how you used my custom layout too. $\endgroup$ – Eric Huelin Nov 29 '17 at 16:35
  • $\begingroup$ I use the speaker icon too, and it works, but have over 500 of them on each of my armatures, what do I do? it takes 2 minutes to disable all of them, and 2 minutes to re-enable. My fingers hurt. $\endgroup$ – Logic1 Sep 30 '18 at 19:44
  • 1
    $\begingroup$ @Logic1 If you select multiple channels you can then use the Toggle Channel Setting (in the Channel menu or Shift-W) to toggle all the selected channel's 'Mute' setting at once. $\endgroup$ – Rich Sedman Oct 1 '18 at 6:23
  • 1
    $\begingroup$ @Rich Sedman Holy smokes! That was way easy indeed!! And to think I just spent the last few hours writing a custom menu just for this blender.stackexchange.com/q/119543/32655 Hey Thank you so much for the tip!!! I owe you a 12 pack! $\endgroup$ – Logic1 Oct 1 '18 at 6:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for?Browse other questions tagged or ask your own question.