1
$\begingroup$

I already try for hours to bake a diffuse map from multiple textures, but the result is always black.

This is my material:

textured object

I want to bake it, I already managed it earlier without any problems to bake the diffuse texture, but now suddenly the only result I get is black.

Here is my node setup for the material which I need to bake. I try to save the result in the node at the top left.
cycles nodes NOTE: I know the Principled BSDF shader settings make no sense, I was just playing around to see if this makes a difference in the bake...

How I tried it:

  1. Selected the object
  2. Created a new uv-image
  3. Create Texture node in my material and set the uv-image as source
  4. Select that node (yellow border)
  5. Bake diffuse

Result:

bake result

There are many lamps in the scene:

lamps in 3D view

$\endgroup$
  • $\begingroup$ Apparently, Baking Diffuse only works, if you're using a Diffuse BSDF, not only a Principled BSDF. $\endgroup$ – Leander Nov 28 '17 at 0:51
  • $\begingroup$ @Leander, thats incorrect, as said I managed to bake the diffuse map without problems before (with the same material), and then I must have changed something and now it won't work anymore. Maybe because I switched to Blender Renderer and then back again? $\endgroup$ – Black Nov 28 '17 at 7:07
  • 1
    $\begingroup$ I had a same problem, then I opened a new file append the object to that seen and did the same baking and ... no problem it worked. $\endgroup$ – user49958 Dec 21 '17 at 20:16
1
$\begingroup$

I found the problem. After setting Subsurface to 0 in the Principled BSDF Shader, it works. I can't explain it though.

$\endgroup$

This site is temporarily in read only mode and not accepting new answers.

Not the answer you're looking for? Browse other questions tagged .