10
$\begingroup$

When I try to run the smoke simulator in Blender 2.62 I get no smoke at all. When I attempt to render, the only output is a black screen. What am I doing wrong here that is making the smoke simulation not render? Is it a mistake I made, or a problem with Blender version 2.62?

$\endgroup$
  • 1
    $\begingroup$ Can you be more specific, just saying something does not work isn't helpful, there could be several things wrong here. $\endgroup$ – iKlsR Jun 12 '13 at 12:57
  • 1
    $\begingroup$ Can you upload the .blend somewhere so it can be looked at? For what reason are you using 2.62? $\endgroup$ – zeffii Jun 12 '13 at 13:35
  • $\begingroup$ I have set up a flow and domain mesh, I have created materials and textures but my voxel data does not work. I cannot get any effect out of the voxel data at all, also, on my smoke generator, on the flow panel my smoke colour box is missing. I am in blender render. I noticed that one of the post state that the shader effect shader is not in untill 2.69 or later is there a plugin that I can get. I have watched the tutorials on Youtube but nobody say's anything about later versions of blender being different regarding the smoke generator. $\endgroup$ – Lindsey Jun 13 '13 at 8:31
  • $\begingroup$ The material is applied to the Domain not the Flow object... which may not be obvious to some. $\endgroup$ – Eli Peters Apr 9 '15 at 15:17
13
$\begingroup$

It sounds like you managed to simulate the smoke, but you can't render it. The reason is probably one of two:

  • You're using Cycles in a old Blender Version
  • You're using Blender internal, but haven't yet setup a material.

If you're trying to use Cycles to render smoke, it is possible now. Volumetric shading (the shader that makes smoke) is initial supported since 2.71. (see Release Log)

Setting up a smoke material is kind of difficult, so read the docs if you want all the details (they also have some screenshots if you get lost).

Here's a quick rundown of how to create the material:

  1. Make sure you're using Blender Internal.
  2. Select Volume from the material type (right between wire and halo)
  3. Set the density to zero (we'll be affecting the density with the texture)
  4. Go to the texture tab and create a new texture.
  5. Change the texture type to voxel data.
  6. In the Voxel data panel, do two things:
    1. Set the file format to smoke
    2. Set the domain object with your domain object's name
  7. Scroll down to the influence panel
  8. Check Density, Emission and Emission Color and leave them all at 1.000.
  9. Hit Render!
$\endgroup$
  • 8
    $\begingroup$ The material setup is indeed quite involved. With any mesh object selected, Object menu > Quick Effects > Quick Smoke will also set up the appropriate Blender Internal material. $\endgroup$ – brecht Jun 12 '13 at 20:58
  • $\begingroup$ @Charles, might want to phrase it "Here's a quick rundown of how to create the material for the Smoke Domain object:", unless i'm the only dummy that tried to setup the flow object :) And to brecht's excellent suggestion, if anyone is confused why it worked at first but then stopped after saving the blend file, just go to the Domain's Smoke Cache and click Bake. $\endgroup$ – Plenus Franckly Nov 21 '13 at 15:58
4
$\begingroup$

For a smoke simulation you need to setup your scene at least with a flow object and a domain. The flow object emits the smoke and the domain is the demarcation of the simulation.

enter image description here

The setup is as follows (all settings are default exept the highlighted Flow and Domain)

The outer cube (domain)

enter image description here

The inner cube (emitter)

enter image description here

$\endgroup$
1
$\begingroup$

I struggled with the exact same issue for hours upon hours and discovered the issue was something small and easily overlooked:

In the Texture tab, after you have changed the texture type to Voxel, go down to where it says Voxel data. Under here, you will see a field for Domain Object. If it looks like a cube with blank space to the right of it, click the blank space in the field and in the pull down, choose "Cube". The field should now say Cube, and your preview should show your smoke.

I hope this helps someone.

$\endgroup$
1
$\begingroup$

After followed a few tutorials, it still didn't work. Finally, I found that another factor is Domain Object's texture mapping coordinates. For some reason, the default settings might not apply any coordinates to the object.

Smoke need coordinate

So, check it when things don't work even you have followed exactly those steps.

Another quick fix is to use "3D Views>Object>Quick Effects>Quick Smoke" as the starting point.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.