2
$\begingroup$

I been looking for this everywhere online and still found no answer. I'm trying to find a way to use freestyle but it slows my render down. How can I use freestyle for certain edges while not rendering the rest of the mesh at all. Like seams almost I just don't even want the render to even see the rest of the mesh. All I want is the outline of certain edges to render quickly. I also have most settings in render tab set low.

Right now I have a cube with outline rendering at 0.15 to 0.20

My question is if there's a way to mark edges to get rendered while the rest of the mesh doesn't even get seen, I think that will speed up the render exponentially.

$\endgroup$
  • $\begingroup$ Could you post a screenshot of it? $\endgroup$ – cgslav Nov 24 '17 at 0:19
4
$\begingroup$

You may use the Edge Mark option of the Freestyle to define what edges would be rendered. enter image description here

Enable Freestyle renderer in Render header-->Freestyle panel. Set the line thickness as you like. enter image description here

Select the edges you want the Freestyle to render, then press Ctrl+E-->Mark Freestyle Edge to make them renderable.
enter image description here

In Render Layers header-->Freestyle Line Set panel check the Edge Mark checkbox. Uncheck the Silhouette, Border and Crease checkboxes to make the contour of the object renderless. enter image description here

Here's the render result:
enter image description here

You can go further and render only selected edges. With the vertices/edges selected in Edit Mode duplicate them with Shift+D and make them a separate object (P-->Selection). Move the original object to another layer and hit render. enter image description here

Here's the result:
enter image description here

Not sure if it is what you're looking for. Let me know if I helped you.

UPDATE: If you want to render only the edges give the object a Transparent shader in Cycles. The Freestyle settings should stay the same as in the examples above. enter image description here

$\endgroup$
  • $\begingroup$ Thanks that helps with the edges a lot :D but it still renders the rest of the mesh. I know I can go into passes and uncheck combined and Z but it still looks for the mesh. How can it care about just the marked edges and not focus at all on the rest of the mesh? $\endgroup$ – Spiritual Learning Nov 24 '17 at 2:13
  • $\begingroup$ I've updated my answer. Hope this is the solution you're looking for. $\endgroup$ – Paul Gonet Nov 24 '17 at 17:06
  • $\begingroup$ As an addition to render only edges of the object drawn with Freestyle you can disable rendering surfaces by unchecking Use Surfaces under Render Layers tab. This will bypass rendering materials and significantly speed up rendering of the scene. $\endgroup$ – Mr Zak Nov 24 '17 at 17:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.