1
$\begingroup$

enter image description here

Having a problem that is really frustrating me. When I render an image, the two boxes that I used for making sinks with a Boolean modifiers are appearing in the picture. I have deleted those boxes long ago and double checked all the layers and they aren't there. Funny thing is render view works just fine.

$\endgroup$
  • 2
    $\begingroup$ I guess they are there somewhere... try selecting the "cut" object (I guess the top element) and look at (or show) its modifiers. If you can't solve, you can share the file on blend-exchange.giantcowfilms.com then edit your question and post the provided link $\endgroup$ – m.ardito Nov 21 '17 at 13:00
  • $\begingroup$ oh my god I am an idiot, after playing around for hours i found out that they were actually hidden in object. I hid them instead of deleting them xD $\endgroup$ – Victor Deno Nov 21 '17 at 13:04
2
$\begingroup$

It looks like your object isvisible in render, but not in viewport. In any case it should still exist in the object list. Try to find objects hidden in viewport but not in render:

enter image description here

Then you can hide them in rendering by clicking the little camera, or just delete them.

enter image description here

$\endgroup$
1
$\begingroup$

If you want to hide a "live" boolean operator object, say while moving it around or otherwise working on it, it's convenient to move it to a separate layer ('M' key or use the Relations panel pictured).

Object layer can be assigned from this panel, multi selection is possible.

You can control visibility of your boolean(s) by hide/showing the corresponding layer (shift-click layer buttons in header). When layer is hidden, it's hidden in all of 3D view, preview and final render.

Setting render (camera icon) property to false in the Outliner, on the other hand, will still show the object when using the render display/preview mode, which may be unintended and annoying since you lose the WYSIWYG aspect as your boolean result is obscured.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.