0
$\begingroup$

edit: thank u guys i solved my problem with dissolving some distorted vertices and adding new ones via knife tool.

Hello everyone i am a newbie at blender. I am watching a character modelling tutorial but i have a problem. For some reason subdivison surface modifier scattered vertices on my models face and it creates roughness . And i dont know how can i gather them like a line. I tried to fix it with repositioning but i couldnt. What i done wrong and how can i fix it?

Screenshots: without modifier

with modifier

corrupted model

$\endgroup$
3
  • 2
    $\begingroup$ Your model has a bad topology. It would be a good idea to upload your blend file to have a precise answer. I would suggest you to make a remove doubles (select all vertex, press w choose remove doubles). You should also flip your normals but it isn't linked to your problem. $\endgroup$
    – Pyros
    Commented Nov 20, 2017 at 14:49
  • $\begingroup$ @Pyros i dont know how can i add a blend file but thank u for your response. $\endgroup$
    – drejanborn
    Commented Nov 20, 2017 at 15:28
  • $\begingroup$ Yoiu can upload your .blend to Blend-Exchange. Once it's uploaded, you'll be provided with a link which you should include in your question. $\endgroup$
    – user27640
    Commented Nov 20, 2017 at 16:16

1 Answer 1

1
$\begingroup$

Here's what your going to want to do.

First, uncheck the little three vertex icon at the top of the subdivision surface modifier (the triangle one). That option makes the vertices follow the subdivided mesh, which can be useful in some cases, but in your case will just lead to confusion and a messy looking model.

Second, select everything in edit mode and press ctrl-N to recalculate the normals. It looks like blender somehow flipped the direction the faces should be pointing, which is giving you the blue color instead of a light grey.

Third, while still having everything selected, press W then choose remove doubles. It's hard to tell from your images but you may have some vertices exactly on top of each other, which can cause some issues as well. This option will get rid of and doubles.

Finally, as noted above, the geometry of your model could use some work. Making clean topology takes a lot of practice, so don't be discouraged here. You really want to avoid using triangles or faces with more than 4 vertices. When using a subsurf modifier with such faces, the modifier cant smooth then out as cleanly as a 4 sided face, and thus you can get rough spots and pinching.

One tool you may find helpful is the smooth tool. Select a portion of your mesh in edit mode, then press w and click smooth. This will even out the mesh a bit and reduce bumps and uneven faces. This usually does result in a slightly flattened mesh though, but using alt-s you can 'inflate' the faces a bit and the result should be pretty good.

$\endgroup$
1
  • $\begingroup$ Thank you for your answer. I love work with blender more under favor of helpful people like you. $\endgroup$
    – drejanborn
    Commented Nov 20, 2017 at 18:13

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .