0
$\begingroup$

I added seams to a cylinder that had a solidify applied to it, the inside is fine and is all connected on the UV map as it should be with the seams I added but on the outside the majority are messed up with a bunch of duplicates that I can't delete.

If I do remove doubles it doesn't remove any verts and if I move the face either on the 3d view or the map it moves the same face with the same verts and edges connected? I've never seen anything like this...

enter image description here

enter image description here

$\endgroup$
  • $\begingroup$ If possible upload the file here blend-exchange.giantcowfilms.com and include link in the question or in comments. Usually if islands in the UV map are split to multiple small ones then there's something with the mesh. Removing doubles might not help due to many reasons, like too low threshold, too high threshold or something alike $\endgroup$ – Mr Zak Nov 18 '17 at 19:46
  • $\begingroup$ download file is at the bottom, thanks for the help! $\endgroup$ – J. Point Nov 18 '17 at 21:53
  • $\begingroup$ I can't tell how was that done but there are overlapping faces in the mesh which cause z-fighting, broken face loops and non-contigous uv map. Removing doubles won't work as expected due to small distance between faces to delete and faces to leave. I'd suggest removing those overlappings maybe even manually. One more flexible approach is removing solidified geometry and using Remove doubles $\endgroup$ – Mr Zak Nov 18 '17 at 23:09
  • $\begingroup$ How do I go about removing the double manually? removing the face seems to delete "both"? $\endgroup$ – J. Point Nov 19 '17 at 0:26
  • $\begingroup$ It doesn't delete both, that's what is shown in the gif. There are some faces which are not overlapping though. To remove solidify see blender.stackexchange.com/questions/81583/… $\endgroup$ – Mr Zak Nov 19 '17 at 0:36
1
$\begingroup$

Smart UV Project works for me on 2.79. I added a primitive cylinder Edit/Face mode/deleted the cylinder top face. Back to Object mode/added "Solidify Modifier" (BTW hate that name), applied "Solidify Modifier". Back to edit/face mode, select all/apply Smart UV Project at default settings. Result is fine.

So are you saying that the faces/verts of the outside of the cylinder are locked to the inside faces/verts?

| improve this answer | |
$\endgroup$
  • $\begingroup$ I'm not using the smart project, I'm manually unwrapping. and as far as I can tell on the model it all looks good, just looks like some faced are duplicated but they aren't... $\endgroup$ – J. Point Nov 18 '17 at 19:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.