I try to import the ThirdPersonController (Ethan) which comes with the "Standard Assets" with all animations, to blender.

I imported the model "Ethan.fbx" to blender by using the FBX importer, with default options.

Ethan 1

The bones are rotated weird, so I changed it to this:

Ethan 2

Now I try to import all the animations into blender, so I can view and edit them. I tried to import the animation HumanoidRun.fbx (again with the fbx importer and default settings) but now another Armature was added:


How can I properly import Ethan to blender with all animations?


2 Answers 2


I know this is an old post, but if anyone experiences the same issue, it's very easy to fix.

To import fbx:

  • Go to File > Import > FBX

When importing the fbx make sure to

  • Select your fbx file
  • Select armature in Import FBX option Area
  • Select automatic bones orientation
  • Select import no desc If it's not working as expecting, play around the primary and secondary bones options, but usually, if your fbx is working in unity, the automatic option will do it for you.

Good luck, never give up - keep the good work :)


The fbx importer in blender has import settings. On the armature tab of import settings, set the

Primary Bone Axis = X Axis
Secondary Bone Axis = Y Axis

Then Ethan will import fine. I'm not sure if the backwards face bones are intentional. I think so.

A lot of the animations are not in the fbx file, the ones provided by standard assets are in other files, are used by the third person controller using retargetting in meccanim.

I found the answer for the fbx importer on digitalrune

Ethan skeleton


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .