0
$\begingroup$

I have a problem with customize hotkeys. For example I want to change Zoom in viewport hotkey from "Ctrl + MMB" to "1 + LMB" how can I do that? I found this command in input preferences, and I can change to any letters hotkeys + Mouse Button, but if I change to numbers + Mouse Button - it's not working.

I'm customized this in Maya and used to it some years ago and it's very convenient for me, so I would like to do the same in Blender.

$\endgroup$
  • 1
    $\begingroup$ What didn't work and what did you try? Note that if assigning 1 (not from Numpad) to another action you need to disable it from layers toggle (3D View (global) > Layers in User Prefs > Input). Also for the property for zooming you change (Zoom View) make sure to change event to Click. Once it's done 1 will invoke zooming and moving mouse will allow change it. Press 1 again to exit. $\endgroup$ – Mr Zak Nov 18 '17 at 10:18
  • $\begingroup$ Thanks for answer, but not quite :( I want to avoid double clicking, because it's slow, I would like to do Press\Release commands like a Maya - for example when I press and hold "1" key I can drag left mouse button and zoomed, but if I release, I will return to previous state. $\endgroup$ – Diffuse Color Nov 18 '17 at 10:47
  • $\begingroup$ I solved the problem, I had a tick Emulate Numpad in left side of Input Preferences. $\endgroup$ – Diffuse Color Nov 18 '17 at 11:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.