0
$\begingroup$

I can't seem to find a solution on here or anywhere else. I have baked two separate normal maps from two different high-poly meshes onto one low-poly one. I did this so I can have the head of the human I'm modelling have quality normals as well as the body.

enter image description here

But now I have a problem, I have both textures made in the panel, but they don't seem to mix well. One of the normal maps acts like a mask to the other one.

enter image description here

I can switch between these, and the regions of the mesh that correspond to the map work well, but they can't seem to work together.

enter image description here

Is there a solution to this?

Here is the .blend file,

$\endgroup$
2
$\begingroup$

You will need to select which UV map is used for which normal map. Go to the mapping panel in the texture tab for each normal map and make sure mapping is set to UV and the appropriate UV map is selected.

Also, when you create a UV map, every face from your object is on every map, so you will need to make sure that the face UVs are on an area of the Body UV map where the texture is transparent and vice versa. If you select all of the faces of your mesh in edit mode and look at each map you will notice that the UVs for the face and body are on each map. Simply select all of the islands for the face and scale them down until they fit on one of the transparent sections on the Body Normals image, and do the same to the Face Normals map but scale down the body island instead.

Also in your case you'll want to turn down the strength of the normals to .1-.2 or something as otherwise they make your mesh quite grey. Your lighting setup is also causing a few of the funny lines and dark/light spots. A single hemi lamp will give even lighting with minimal shadows so you can more clearly see what's going in with your maps.

$\endgroup$
  • $\begingroup$ Thanks for the suggestion, but I already have that sorted out. Is there another possible reason this is happening? Could it be under the influence tab that I have change the mixing mode? $\endgroup$ – Krillinslosingstreak Nov 17 '17 at 21:19
  • $\begingroup$ You could try setting the extension on each texture to clip instead of repeat in the image mapping panel. $\endgroup$ – Brenticus Nov 17 '17 at 21:26
  • $\begingroup$ Sorry, that doesn't seem to work, thanks for the help so far though. Do you think I should post the blend file or try to bake the high-poly into one normal map rather than two? I'm not too keen on doing that for a couple of reasons, but I can try instead. $\endgroup$ – Krillinslosingstreak Nov 17 '17 at 21:30
  • $\begingroup$ Posting the blend file would be very helpful. $\endgroup$ – Brenticus Nov 17 '17 at 21:32
  • $\begingroup$ I got the files zipped and ready to share, though I can't use the blend file upload site since the file has both the .blend and the textures that come along with it. What file sharing site would like to me give it to you from? $\endgroup$ – Krillinslosingstreak Nov 17 '17 at 22:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.