0
$\begingroup$

I made an image with text and drawings to simulate play pause and other audio buttons and made it black for using it like a mask; where one material is shown through the image and other material from everything else. However, it only shows one material and even using it like a normal image texture through the diffuse or something isn't working and doesn't show. I made it before with other renders and never had this problem if it is important I'm using blender 2.79 this are the nodes how I'm using it

these are  the buttons where i want to show bot materials

this is the unwraped model and the texture i madethis is the rendered buttons only in preview ignore the background is the hdri image not showing because I'm out of the camera view but it shows only one material is not showing the emission or whatever

$\endgroup$
2
$\begingroup$

Your mix shader mix input should be feeded by alpha output of the texture, not from the color output (which gives you 0.0 for black and 0.0 for transparency).

Enable node wrangler addon and Ctrl click on nodes to see their output and check the nodes workflow.

$\endgroup$
0
$\begingroup$

You are encountering this issue due to the texture being black, in order to fix this, you need all of the buttons (that you want to glow) to be white.

e.g.

Result

Texture:

Setup

Change it to white and then use that version of the texture and you should be good.

Related: I would like to apply an emission shader to specific parts of a texture

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.