1
$\begingroup$

I'm trying to model the nucleoprotein complex of influenza A which schematically looks like this:

enter image description here

I'm struggling with the modeling of the RNA part (the black string on the image). One of my objectives is to model 8 segments of precise size, so my RNA is made of a lightly modified cube ("nucleotide" in the blend file) with an applied array modifier. The RNA used in my blend is the shortest (890 nucleotides).

Using the Extra Objects Addon, I've been able to model a double helix structure. Then I've added a loop and merged the three curves.

The last step is to make the RNA taking the shape of the curve. So, I tried using the curve modifier (with different deformation axis, with array applied or not, with array on "fit curve") but nothing is changing. And I'm not sure about what is going wrong (the curve has a HUGE number of vertices, could it be the problem?). Have I made a stupid error, or should I use another method?

$\endgroup$
3
$\begingroup$

It appears that every vertex of the curve has a double that isn't connected. Go into edit mode on the curve, select one of the connected vertices(not the handle) and press Ctrl+L to select the linked ones, then Ctrl+I to invert the selection to get the disconnected vertices, and then delete them.

For some reason the array modifier still doesn't work with the fit curve option, but the simple alternative is to add an array modifier with fixed count and then a curve modifier below that.

You may also want to make the rna mesh object contain only a small number of nucleotides so that you can make the rna fit the length of the curve better.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.