7
$\begingroup$

I made a low poly piece and realized that in the 3D viewport with rendered mode enabled that I have some artifacts on the boundaries of faces, if you look closely it looks like scratches.

enter image description here

enter image description here

Can anyone help me in my debugging process of understanding what's wrong? I'm still a beginner on Blender, and there's so much I ignore on the good ways to do things.

Here are the viewport clipping settings:

enter image description here

Here is the component in question: Blend

Originally I tried to fix this problem using BSurfaces, but this was giving me unrelated error messages:

$\endgroup$
  • $\begingroup$ Tkx Zeffii, but I've already seen almost all the videos concerning my problem, and forums too. It seems I'm not the only one not to be able to use this tool. $\endgroup$ – Kriss Jun 12 '13 at 9:52
  • $\begingroup$ Indeed, I used boolean operations to get the holes in the mesh. As you've adviced me, I posted on pasteall.org the .blend of that element under the name of : Solar car bracket.blend.<br/>BTW, it's very encouraging to read your answers. Thank you so much ! $\endgroup$ – Kriss Jun 12 '13 at 12:34
  • $\begingroup$ Be sure that you're not in Local View with BSurfaces. It will fail otherwise. You must be in Global View. $\endgroup$ – Jonathan Williamson Jun 12 '13 at 16:10
  • $\begingroup$ Is that windows XP I see?? $\endgroup$ – Azmisov Jun 12 '13 at 16:45
  • 1
    $\begingroup$ Voting to close, this is a bug report. also. if its not the GPL one you best contact the author direct. $\endgroup$ – ideasman42 Jun 12 '13 at 23:21
6
$\begingroup$

Your real problem appears to be scale:

enter image description here

I think caused by clipping plane being way beyond what is necessary.

enter image description here

You had it set to 1mm - 1km

Overlapping faces

My first impression is that you are trying to fix the wrong problem. I suspect that the reason you are using BSurfaces is because you don't know why you are getting scratches. The scratches is a much more interesting problem, and knowing how to fix those will help you in future modelling.

If I am correct, the 'scratches' as you call them, are the result of overlapping geometry, and this results in z-fighting. The scale you are modelling at compared to the viewing world scale will result big enough rounding errors to make this noticeable.

$\endgroup$
  • $\begingroup$ First, thank you very much for your help. $\endgroup$ – Kriss Jun 12 '13 at 12:22
  • $\begingroup$ I draw the strokes exactly the way you show it, and the result remains the same with the same error message. Impossible to get any new face. $\endgroup$ – Kriss Jun 12 '13 at 12:25
  • $\begingroup$ @Kriss please upload the component to dropbox or pasteall.org so we can see the 'scratches', which I think is more interesting to you. We can figure out BSurfaces too, i'm sure. The reason I focus on the component instead of the BSurface issue for now, is because in my estimation when we solve the BSurface issue, the original 'scratches' problem will not be solved. $\endgroup$ – zeffii Jun 12 '13 at 12:29
  • $\begingroup$ OK Zeffii, I've posted my component on pasteall.org under the name of 'Solar car bracket.blend'. Even if I've never used pasteall.org, I guess you could find it just with its name. $\endgroup$ – Kriss Jun 12 '13 at 12:42
  • $\begingroup$ @Kriss in the future, please post the .blend in the question so others can see it and better help. $\endgroup$ – iKlsR Jun 12 '13 at 23:51
6
$\begingroup$

I downloaded your .blend file just to have a go, and although I have not been able to reproduce the 'scratches' I have noticed that the scale of the object in the Properties panel is incredibly small.

I tried the 'Apply' function: Ctrl A > Rotation & Scale, to bring all three dimensions to 1.000, and found that the render result was different before and after.

enter image description here

Before Ctrl A Before Ctrl A

After Ctrl A After Ctrl A

Before Ctrl A Before Ctrl A

After Ctrl A After Ctrl A

You could try this to see if it improves your result. Oh, and I removed the Mean Crease you had set on your edges (I'm not sure what that was for!).

$\endgroup$
  • $\begingroup$ Hi SteveW ! Thanks for the tip to set the 3 axis scale to 1. Another new thing I've learned :) I'll ge into the habit of using it now. About the Mean Crease, I set it when I planned to subsurfaced my object. Now it's no longer useful. $\endgroup$ – Kriss Jun 13 '13 at 8:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.