0
$\begingroup$

I'm pretty new to Blender, but I have a model in which I defined a bunch of Sensors, Controllers, and Actuators that move my model in response to the keyboard in the blender game engine.

When I press [P]lay, the keyboard sensors I defined all work just fine. But when I look in the logic editor it doesn't show any sensors controllers or actuators. I don't know what changed between the last time I looked at the model and now.

Is there any way I can somehow hide my definitions of sensors, controllers, and actuators in some other layer or somewhere that I perhaps don't know about?


This is what I see, but a half dozen logic bricks still function as expected.

enter image description here

$\endgroup$
  • 2
    $\begingroup$ I have a model in which I defined a bunch of Sensors, Controllers, and Actuators... In the image i see that the selected object is a Camera, select your model. As you are new i assume that you dont know that each object have independent logic sensors, etc. that can be linked to controllers of other objects $\endgroup$ – Strapicarus Nov 16 '17 at 6:14
  • $\begingroup$ Oh duh! I absolutely did not know that. Thank you, I thought I was going crazy. :) Please do post that as an answer, that's exactly what I needed to understand. @Strapicarus $\endgroup$ – davidparks21 Nov 16 '17 at 17:08
1
$\begingroup$

I have a model in which I defined a bunch of Sensors, Controllers, and Actuators... In the image i see that the selected object is a Camera, select your model. As you are new i assume that you did not know that each object have independent logic sensors, etc. that can be linked to controllers of other objects.

Blender Manual: Game engine

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.