1
$\begingroup$

I have been following Kent Trammel's YouTube tutorial series on creating a realistic head within Blender without many obstacles. In part 3 (https://www.youtube.com/watch?v=KoiYMx2xXGA&t=27s) he bakes a displacement map from his multires mesh (seen at 5:42). However, when I attempt this I am greeted by "You should have an active texture to use multires baker". This issue has been raised before with various solutions (https://blenderartists.org/forum/showthread.php?319591-Multires-Baker-You-should-have-active-texture , How to pick target texture image for baking?) yet after trying each one I get the same message.

In the images below you can see that I selected my UVs and created an image Untitled.001.enter image description here I also assigned this texture to my material.

enter image description here

and the texture even shows textured view enter image description here

yet I still get the error message.enter image description here

I have been trying to fix this for hours now, so any solution would be greatly appreciated.

$\endgroup$
  • $\begingroup$ Try removing texture from the material, removing it from the UV editor (with all faces selected in UV editor press X button to remove texture and then assign again by selecting it from the dropdown list) and baking again. For Blender Internal material isn't important, it's assigning textures per faces. If nothing works upload the file and include the link here $\endgroup$ – Mr Zak Nov 14 '17 at 22:13
  • $\begingroup$ @MrZak Thanks for the suggestion. Alas, after following your steps exactly, it still didn't work. And at over 8,000,000 faces, the blend file is 148MB (well over the blend-exchange limit). I've deleted background images and compressed the file to 100MB, so if you really want to take a crack at it you can find it here drive.google.com/file/d/1G3jAoBwKXTRBOJZiW8fKWbFux5xGL4-a/… otherwise I'll probably look into starting over. $\endgroup$ – Gage Benham Nov 15 '17 at 0:08
  • $\begingroup$ It would be easier if you separate e.g. the head as the problem mesh and save it into a new file and upload that one. 100mb is a lot but even more is 8mln faces which can be a problem to operate on lower end hardware. You might also find useful developer notes about the baker $\endgroup$ – Mr Zak Nov 15 '17 at 11:07
  • $\begingroup$ @MrZak Thank you for that link, the developer notes seem like a helpful resource for future projects. I went ahead and removed 4 multires levels, bringing down the model geometry to 250,000 which translates to a 23MB [file][1] [1]: blend-exchange.giantcowfilms.com/b/4114 $\endgroup$ – Gage Benham Nov 15 '17 at 20:42
0
$\begingroup$

Not all faces of the mesh are assigned to that texture so baker can't start working due to that.

The culprit is that some faces of the mesh are hidden, never fall under selection hence don't get assigned to the texture in UV Image editor. Unhide them in Edit mode with Alt+H. Only unhidden geometry is selected in the screenshot below.

screenshot-overlapping-skin-on-the-face-can-be-dangerous

Note also that while baking will work once you select all after unhiding and assign to the texture, it's better to fix that area as it's non-manifold geometry which can cause some troubles down the road.
Select overlapping edges and remove them:

screenshot-painfully-selected-edges-on-the-face

Also there're overlapping vertices on the back of the head left probably after applying Mirror modifier. To avoid UV map corruption don't delete them rather than use Alt+M to join them at center:

screenshot-seam-in-the back-of-mesh

$\endgroup$
  • $\begingroup$ Thank you so much. Following your steps, I was able to bake a displacement map and save myself from hours of frustration. That being said...!(ibb.co/jtms56) When I do bake it, I'm left with a solid gray displacement texture. $\endgroup$ – Gage Benham Nov 15 '17 at 23:52
  • $\begingroup$ @GageBenham It wasn't mentioned in this answer, it should be somewhere in developer notes and here as well: in order bake to work as expected there should be some difference in the levels of the Multires (View vs Sculpt/Render) $\endgroup$ – WKG Nov 16 '17 at 1:16
  • $\begingroup$ That solved it. Thanks again for your help! $\endgroup$ – Gage Benham Nov 16 '17 at 18:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.