0
$\begingroup$

As we know, plane kind of meshes have only one face. My mesh has 2 dimentional faces on the edge.I want to give those faces alittle thickness so it would not dissapear when looked from backside. But when i exture the face, it extrudes only edges, not face. i tried it both way. Why does it do that ?

My Mesh:

enter image description here

Face extruded both way to experiment:

enter image description here

enter image description here

$\endgroup$
  • $\begingroup$ Hm. There's a dot that indicates a face, try recalculating normals (select all then Ctrl+N). $\endgroup$ – SilverWolf Nov 13 '17 at 21:02
  • $\begingroup$ i tried but still same. I have uploaded the mesh and added it to my post in case it is liked to be checked. $\endgroup$ – Mehmet Nov 13 '17 at 21:21
  • $\begingroup$ Thanks. Also, for future questions, please note that that particular site has quite broad licensing terms; you can see more here. Although as long as you know that going in and are OK with it, then it's fine. $\endgroup$ – SilverWolf Nov 13 '17 at 21:27
  • $\begingroup$ i know but it is not a completed nor complex mesh. So it is ok. $\endgroup$ – Mehmet Nov 13 '17 at 21:39
  • $\begingroup$ As you have Backfacing Culling enabled faces with normals pointing in another direction aren't shown (or shown as dot). Looks like you want to solidify the mesh entirely. This is done either with modifier or by extruding all the faces and scaling along their normals; if extruding only some faces you'll get non-manifold geometry. $\endgroup$ – Mr Zak Nov 13 '17 at 21:58
1
$\begingroup$

Ok, i chose those faces and unjoined from rest of mesh and tried again. This time it worked. So it must be faces, next to them, causing the problem. But when i unjoined and extruded those faces, shading looked alittle weird. Also i didn't want to apply solidify to the whole mesh to prevent from unnecessary polygons. In the end, this is what i made.

I made over the mesh.

1.I applied solidify on a basic cylinder

enter image description here

2.Then gave details to outer face only and my problem seems to have fixed

enter image description here enter image description here

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.