0
$\begingroup$

https://drive.google.com/file/d/1q3kcN4hKMkdARc4XzEbYOsSwoWuhSzKA/view?usp=sharing

Here's my Blender File

I can make the object active.

But when I click the smooth option, nothing happens.

$\endgroup$
1
$\begingroup$

It looks like most of the faces in the model are disconnected. When you activate smooth shading on disconnected faces, Blender treats each one individually and it looks like flat shading because each face's boundary is handled independently from its neighboring faces.

It's best to model (or import) objects with connected faces if you want to use smooth shading, but here is a quick and dirty way to join most of the faces in your model:

  1. Select the object.
  2. [TAB] into Edit Mode.
  3. [A] to select all vertices.
  4. Mesh > Vertices > Remove Doubles

This will join most of the faces and you will get smooth shading for the most part. You will probably need to manually repair some faces to get it working across the entire object.

$\endgroup$
1
$\begingroup$

Go to Vertex Tab and uncheck Auto Smooth

enter image description here

Go to Edit Mode Press W Remove Doubles

Now u have loose the geometry or unfill Faces

Select all and Press Alt+F

Press Ctrl+N Flip Normals

Now click on Smooth Shading.

enter image description here

$\endgroup$
  • $\begingroup$ This is a better fix than what I offered. $\endgroup$ – Ron Proctor Nov 12 '17 at 7:46
0
$\begingroup$

Click on Clear Custom Split Normals Data under Geometry Date, enter image description here

$\endgroup$
0
$\begingroup$

I ran into this myself and wondered, why this would happen since my mesh was perfectly fine. In order for the smooth shading to be applied to the entire mesh, you have to select it first by pressing A in Edit Mode.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.