2
$\begingroup$

Blender Low FPS Screenshot

I'm not sure if it's even related, but in the top right corner of the viewport you can see it shows 5FPS.

I just downloaded Blender today and been trying to fix this problem for hours. My Blender is lagging, everything is unresponsive and the viewport is 4-10FPS at all times. I'm running out of ideas what to do.

What I tried to do so far:

  • NVIDIA Control Panel, disabling FXAA
  • Couldn't find a setting for integrated graphics, nor could enable it
  • Disable Shadowplay and restart PC
  • Update NVIDIA drivers and downgrade to an older version
  • Re-installing Blender (twice)
  • Changing Blender settings like filtering and window draw methods

GPU: NVIDIA GeForce GTX 1060 6GB (no OC)

CPU: Intel i5 4460 (no OC)

Motherboard: MSI B85-G41 (MS-7850)

RAM: 16GB DDR3

OS: 64-bit Windows 7

I know there are other questions like this, and I tried the solutions, but they didn't help. If you need any other info then ask. Thanks ahead!

EDIT:

I found out one thing - if I make the viewport smaller, then it doesn't lag anymore. And if the window size is still maximum, but I make the viewport small, then nothing lags as well. But why should even lag when it's bigger, if nothing is taking CPU/RAM? This is how everything is when Chrome and Blender are running (CPUID HWMonitor):

GPU

Other

More (probably not important): https://pastebin.com/Ts9MN0Kz

$\endgroup$
  • $\begingroup$ this is pretty normal unless you bake an animation or render it then the viewport will only get 5-8 fps $\endgroup$ – The_RedstoneBldr Nov 11 '17 at 22:17
  • $\begingroup$ That is just something I noticed, everything including the UI is laggy, taking up to a second to respond. $\endgroup$ – Marked as Duplicate Nov 12 '17 at 9:36
1
$\begingroup$

Hmm in viewport try do a factory reset, press space and write load factory settings. Open up some monitoring programs, for GPU, cpu, ram and HDD. try see if anyone of them is being overloaded or overheated. third, is a question, is it anything in the viewport as you test?

$\endgroup$
  • 1
    $\begingroup$ No, I just have a basic cube. I did reinstall Blender multiple times, but a factory reset didn't help. Only 4GB of RAM (of 16), and 30% of CPU is being used total. Nothing else than Blender is taking memory, I did set Blender's priority to high hoping that would help, it didn't. $\endgroup$ – Marked as Duplicate Nov 12 '17 at 9:33
0
$\begingroup$

I finally found a solution after countless attempts.

For any other future people having this problem as well, I fixed it by downloading it on Steam instead of blender.org and the lag was gone.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.