The Scene

So in the scene i have a high poly model and a flat plane to which i want to bake the normals on to. The engine i am using here is Blender Render enter image description here

The Models

Just a flat plane (to which i want to bake the normals on) and the high poly sculpted mesh enter image description here

The texture settings of the flat plane

Regular normal map settings here, checked the normal in the Influence and checked the normal map option in the Image sampling panel

enter image description here

The Anti-aliasing and Bake settings

Regular normal bake settings with the anti-aliasing turned on.

enter image description here

The Question

As you can see the normal map still has jagged edges despite anti-aliasing being enabled. I baked it multiple times to see if it worked, but still got nothing. They still bake out with jagged lines. I am at the ends of my wit here. How do i fix it ? enter image description here


2 Answers 2


TexTools for Blender was recently released (free) which adds an anti-aliasing option for baking.

Anti alias option

Internally the add-on just renders at 2x or 4x the size and then down-scales the final bake to the target resolution resulting in anti aliasing. The good thing is that this anti-aliasing works with all bake modes in TexTools.

You can find more information and download links from my website.

  • 2
    $\begingroup$ Welcome to Blender Stack Exchange! Please not that you must explicitly state it's your own website you're linking to: read How not to be a spammer. $\endgroup$
    – Glorfindel
    Jan 26, 2018 at 9:24

As far as I know there is no way to anti-alias normal baking in blender internal with the standard feature-set. The fastest workaround is to quadruple your texture bake size and then resize/resample it with an image editing program to the desired size.

Alternatively you could try the yPanel addon https://youtu.be/ghJgnjskwyM?t=379 Download: https://github.com/ucupumar/yPanel

Be advised this is a relatively fresh addon and i have no idea how well it works.

  • $\begingroup$ I have tried it, the jagged edges are still there. The problem is that the anti-aliasing works (without the addon) when I try to bake some other object. There seems to be something wrong with plane or the sculpt mesh but I can't figure it out. $\endgroup$
    – Retrax
    Nov 7, 2017 at 16:19

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .