1
$\begingroup$

I set up a texture so the hair can grow in the lighter areas denser. The emission number is set to 5000, and texture is the FacialHair.

Right now, it just moves to one side and ignores the white on the top.

I reloaded the texture, and the hair is not going to those parts. Why is it not following the texture?

enter image description here

The node setup is just an Image texture leading into the color for a diffuse shader. A Texture Coordinate with the UV output is attached to the Image Texture.

When I paint white in one spot, it usually appears above and below. It I draw a little farther up, the hair moves up and down a little more. Is this a Mapping problem?

$\endgroup$
  • $\begingroup$ Did you try entering Object mode and then returning to Texture Paint? What mapping is used for the particles density texture? $\endgroup$ – Mr Zak Nov 6 '17 at 12:16
  • $\begingroup$ I unwrapped the mesh, created a texture, 2048x2048 and that was black. That's all I really did to make the density map. $\endgroup$ – Akados Nov 6 '17 at 14:38
  • $\begingroup$ It's more important what mapping you choosed than what texture resolution you use. DId you try setting Mapping to UV? $\endgroup$ – Mr Zak Nov 6 '17 at 15:04
  • $\begingroup$ It may be that. Where would I set the mapping to UV? I have the Texture Coordinate UV output going into the image texture node. Is that what you mean? $\endgroup$ – Akados Nov 6 '17 at 16:50
  • 1
    $\begingroup$ In the particle system texture settings open the Mapping rollout and chech what option is choosed in the Coordinates dropdown. It is closed on your screenshot so it's not visible what option is used. Nodes won't control that $\endgroup$ – Mr Zak Nov 6 '17 at 18:10
1
$\begingroup$

In the comments Mr Zak provided an answer that turned out to be the correct answer:

In the particle system texture settings open the Mapping rollout and chech what option is choosed in the Coordinates dropdown. It is closed on your screenshot so it's not visible what option is used. Nodes won't control that.

To clarify, here's an image of that particular texture slot:

enter image description here

| improve this answer | |
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.