0
$\begingroup$

I have a mesh that is not behaving the way I expect when it comes to smooth shading. For example, here is the mesh (it is all one piece) shaded smooth (as compared to a Blender Cylinder to highlight the differences):

enter image description here

And here it is shaded flat (again, as compared to the cylinder)

enter image description here

I expect the handle area to be smooth just like the cylinder (you can notice the purple structures smoothing some edges, but not all).

I already:

  • Made sure there is no edge split modifier on the mesh
  • Selected all edges and did a Clear Sharp operation
  • Selected all vertices and removed doubles in case there are un-merged vertices

Here's the file for reference:

$\endgroup$
  • $\begingroup$ Exporting the mesh as an obj and then re-importing it shows that all edges are marked as sharp. Clearing the sharp edges fixes the issue. However, the original blender model is still behaving strangely as if its data structure is corrupted. $\endgroup$ – Samaursa Nov 1 '17 at 22:00
  • $\begingroup$ @MrZak there are no internal faces as far as I can tell (I deleted just one face and it made a hole instead of showing another face if there was any). Please see my comment above where it seems that the blender mesh itself got corrupted somehow...? $\endgroup$ – Samaursa Nov 1 '17 at 22:01
  • $\begingroup$ If you want someone to look into your file then upload it here - blend-exchange.giantcowfilms.com, corrupted data structure is something I expect as the last possibility (and I can't imagine how can that be done) $\endgroup$ – Mr Zak Nov 1 '17 at 22:02
  • $\begingroup$ @MrZak Thanks, I have uploaded the file. It is a fairly simple model. I'm sure I must have done something accidentally. $\endgroup$ – Samaursa Nov 1 '17 at 22:06
  • $\begingroup$ You have AutoSmooth enabled, see blender.stackexchange.com/a/8720/1245, in general it's (almost) the same as Edge Split mod. As the object is pretty lowpoly there isn't much difference in the smooth and flat shading, still it can be seen in Solid shading (e.g. horizontal loopcuts). Either increase its threshold or deactivate it. $\endgroup$ – Mr Zak Nov 1 '17 at 22:14
1
$\begingroup$

Just disable "Autosmooth" option.

enter image description here

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.