8
$\begingroup$

I created an animation for Halloween and I want to add a wispy smoke effect to the eyes and mouth but the smoke stays inside the object.

Jack-o-lantern Animation

I am using a boolean modifier with an animated object to create the eyes & mouth, I first thought perhaps the smoke can't see the holes as the modifier wasn't applied but that didn't help. I have also watched numerous smoke tutorials but none address the issue I have.

Could you look at my blend file and let me know what I'm missing?

$\endgroup$
11
$\begingroup$

It looks like the resolution you are using for the smoke domain is too coarse. This makes the size of a smoke voxel possibly comparable or bigger than the apertures, preventing the smoke to "see" that they are there. By increasing it to 64 I've managed to see the smoke escape from both eyes.

enter image description here

To make sure that the smoke would come out within the time frame (I've done a test bake of 170 frames), I've also increased the time scaling factor, and I've added a starting normal velocity to the Flow object.

I'm not sure whether it counts, but I've also changed the obstacle type to "Animated" (doing this alone isn't enough, you'll still need to increase the resolution)

| improve this answer | |
$\endgroup$
  • $\begingroup$ LOL thanks so much. Resolution was probably the only option I hadn't tried :) $\endgroup$ – chris loughnane Oct 30 '17 at 14:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.