1
$\begingroup$

I have been working on a scene with a model linked from a local .blend file. This local file has now accidentally been deleted, so I'm left with a model I can't interact with in any way because the link is broken. When I select it, it's marked as an "Empty".

I can still see the model, materials and everything, I just can't edit any of it. The file size is also the same. Since I can visually see the model, doesn't that mean the data is stored in the file somehow?

Is there a way to "extract" this data, so I can get the model editable again? So far I have tried these things:

  • Spacebar > Pack Blender Libraries
  • Select model > Object > Make Local > Selected object
  • Select model > Ctrl+Alt+P to make a proxy

None of these things have worked. :(

$\endgroup$
  • $\begingroup$ I wonder why you can still see the model. Usually, if the lib file is not found for some reason, you should only see an empty and nothing else when you open the main file. Possibly you have packed that lib into your file before already? Or have you left your main file open all the time? $\endgroup$ – aliasguru Oct 28 '17 at 5:31
  • $\begingroup$ I may have packed the lib at some point, but it seems like it doesn't matter now the link is broken. This is how the model looks in the Outliner: imgur.com/vKSQeXM I'm not sure what the sphere/cube symbol means. When I hover over it, it shows the location to the now deleted .blend file in a little pop up. The controls for visibility, selection and render are also disabled. $\endgroup$ – Peter Oct 28 '17 at 5:59
  • $\begingroup$ If you still see the model in the 3D Viewport, it's very likely you've packed the liraries at some point. If that's the case, hitting Spacebar in the 3D View and searching for unpack Blender libraries should extract them back to the hard drive. $\endgroup$ – aliasguru Oct 30 '17 at 19:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.