2
$\begingroup$

i have a problem that loopcuts are throwing shadows when i render. I basicly want an area to look like it was one face instead of multiple. Her is an exeample what i mean:

This is my model: http://abload.de/image.php?img=solidshadeg2cgd.png

and this is it rendered. The red circles show what i mean. It's more pronnouned when i look from other angles.

enter image description here

The lines in the first red circle i could life with, but the lines in the 2nd look really ugly from other viewpoints. If i delete all the faces and make one big ngon face from it it looks nice, but i of couse want to avoid ngons. So how can i fix/align this, so that it looks like it was one face?

$\endgroup$
  • $\begingroup$ Could you maybe isolate the offending object into a separate .blend and post it here? $\endgroup$ – Michal May 12 '14 at 20:30
  • $\begingroup$ Sure - i have made a blend. The bigger object is in it and also a seperate copy of the main problem "face" file-upload.net/download-8912541/looppiece.blend.html $\endgroup$ – Biene Maja May 12 '14 at 21:50
  • $\begingroup$ The file upload site you used has spam pop-up windows. Instead, you can link in blend files using pasteall.org. With pasteall you can upload blend files, python scripts and images. $\endgroup$ – MarcClintDion May 19 '14 at 16:11
7
$\begingroup$

A series of narrow/thin faces like this will easily lead to such problem if the "big face" isn't as flat as they were coplanar. So the main problem here is about topology actually.

Try following steps to solve this issue:

  1. Select all narraow/thin faces that form the "big face", then press F (or X > Dissolve Faces) to make it as a big Ngon face;
  2. Press Spacebar and search for Split Non-Planar Faces (or access from Mesh > Clean up > Split Non-Planar Faces); F6 to adjust the max split angle until you get the expected result. (In your particular case, setting to 0° will triangulate it too, which means you can ignore step 3 below);
  3. CtrlT to split Ngon faces into triangles. (optional)

enter image description here

Tip: For Step 2, You can also split it manually instead. Two nice ways are:

  • Press K to enable Knife tool, then cut line(s) on the big face;

  • Select two vertices, then J to connect them by adding a new edge on that face.

Either way above can help when doing retopology.


If you really don't want to change the topology too much, then a quick and dirty way at least would be:

enter image description here

$\endgroup$
  • $\begingroup$ @BieneMaja You are right. it's just simple rotating and scaling, but you have to rotate from at least two different views (e.g. front view and side view). All in all, the AO shadow here denpends on how flat that area is. $\endgroup$ – Leon Cheung May 14 '14 at 1:20
1
$\begingroup$

enter image description here

When you add more geometry to these non-planer areas then you can easily end up with many more non-planer poly's which becomes more difficult to clear up. You can fix this when the model is still very simple by aligning the view from different angles and adjusting points one at a time until the area looks flat from every direction, once all that's done then start adding more geometry.

Now I also see several loop cuts that are really close together and this can exaggerate the non-planer issue because the thinly sliced quads can become overlapped. There are several cases of this happening here.

I think to start with, it's a good idea to test whether or not loops are too close by zooming out and making sure that you can still see a clear distinction between individual loops.

To help clear this up you can activate Edge Selection mode then use Alt+Click to select an entire edge loop and double tap g to slide the edges around until they are more even.

You may have also noticed that when you first create an Edge-Loop that you can slide it around before pressing Enter to set the Loop. Use this to control exact placement when creating them.

There are also many extra Loops in there that are likely unnecessarily because generally they are only needed close to the edges but not normally across flat surfaces between the transitions(I'm sure many people have reasons to do this but in your case I would avoid it for now until you are sure you need to do this).

Now to remove unwanted Edge-Loops, you can select a Loop using Alt+Click as before and press x then g. This will first open the Delete menu then activate the Edge-Loop delete function. This is a great way to clean up a model.

enter image description here

$\endgroup$
0
$\begingroup$

This method may change the shape of your model slightly.

Select all the faces you want aligned or look as one face, and scale them to 0 along the normal axis (you can change it from global to normal in the toolbar)

Here's the before and after:

before after

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.