2
$\begingroup$

Strangely, wires are not drawn on the masked selection (yes, the very selection you've masked off and are trying to paint). Does anyone have a reasonable workaround for this behavior?

Edit mode: faces selected to mask. "Wire" and "Draw all edges" checked:

enter image description here

Texture paint mode: Face selection masking disabled:

enter image description here

Texture paint mode: Face selection masking enabled (wires are not drawn on the masked faces):

enter image description here

$\endgroup$
3
  • $\begingroup$ Could you show some screenshots of what you have and maybe where you want to see the wire? Maybe try exporting UV layout and overlaying it on the mesh as additional texture (it's more like workaround of course) $\endgroup$
    – Mr Zak
    Commented Oct 27, 2017 at 22:25
  • $\begingroup$ post updated with images $\endgroup$
    – Doom Guy
    Commented Oct 28, 2017 at 2:39
  • $\begingroup$ This is indeed present behaviour, the wireframe won't be shown on the selected faces with Face selection masking enabled. I didn't ever find any workaround for that, although in general situations it wasn't really needed. $\endgroup$
    – Mr Zak
    Commented Oct 28, 2017 at 22:16

1 Answer 1

1
$\begingroup$

I have used this technique for a long time now. Make a square texture with a colored border, I make mine with transparent center square and a blue outer rim. On the object to be painted, assign a new uv map and unwrap it, reset it so that it is all faces overlapped as a square. set the texture to use this second uv map, and set the main texture as the active painting slot. I set the square texture to 'Multiply' instead of Mix, and I use GLSL to make sure I see the effect of the texture over the main color texture. I am including a screen shot to show that the texture simulates the wireframe you want and works while you are using face selection masking.overlayHere is the texture enter image description here

$\endgroup$
1
  • 1
    $\begingroup$ Awesome, I'll give this a whirl! Thanks! $\endgroup$
    – Doom Guy
    Commented Oct 30, 2017 at 15:00

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .