0
$\begingroup$

I have a scene that rendered perfectly with my GPU, in 960x540. As I had a Cuda error when trying to render this scene in 1920x1080, I decided to use Render Layers. Now, I have a Cuda error every time I try to render it, even in 960x540... And when I erase all the Render Layers, it renders just fine.

I don't really understand why using Render Layers does this, as it should do the opposite :/

Edit :

The error is "Cuda error: Out of memory in cuMemAlloc(&device_pointer, size)". I'm using Blender 2.79, my graphic card is a GTX 960 with 4GB of VRAM. I'm using Linux Mint 18.2. The scene uses 112Mb of memory: it's a pretty simple scene with less than 20 objects and one lamp, a particle system, two 3K textures and Adaptive Subsurf on some objects. There are 74,873 tris.

Edit 2 :

This is not the same problem as here : CUDA error: Out of memory in cuMemAlloc(&device_pointer, size). My problem is related to Render Layers, as said before.


Sorry for the engrish :X

$\endgroup$
  • 1
    $\begingroup$ Are you waiting for an answer? Without even actually TELLING US the error message? Also, which GPU, how much VRAM, memory usage of the scene, etc, etc. $\endgroup$ – Reaper Oct 27 '17 at 14:11
  • $\begingroup$ @Reaper I updated the post $\endgroup$ – Tuxbot123 Oct 28 '17 at 13:57
  • $\begingroup$ Related: blender.stackexchange.com/questions/61637/… $\endgroup$ – Reaper Oct 30 '17 at 7:22
  • $\begingroup$ @Reaper, no it's not the same thing. My problem is related to Render Layers, as said in the post. $\endgroup$ – Tuxbot123 Nov 4 '17 at 14:59
1
$\begingroup$

When using Render Layers don't forget exclude layers, if they invisible.

enter image description here

If you doesn't exclude layer, it will be loaded into memory even if turned off. Objects on invisible layers will be visible in reflections, shadows, and can be mask (Mask Layer option). So, if you really want to layer don't load into memory, mark them as Exclude.

$\endgroup$

Not the answer you're looking for? Browse other questions tagged or ask your own question.