0
$\begingroup$

I'm SUPER frustrated with the UVmapping in Blender. I'm also a frustrated with working with nodes which admittedly is mostly my own ignorance.

I have an object I want to be blue except for the two decals I have placed. But blue only appears on the faces that I've uvmapped the decals onto. I've marked in the photo below some locations that should be blue.

enter image description here

Here is my node setup.

enter image description here

I must be missing something.

Here is my blend file... https://drive.google.com/open?id=0B8ZnFrE6fxi_R29mZnBkXzF5dm8

EDIT:

I also tried this setup which produces the exact same unwanted result. It is curious because it worked for the rear portion of my Zamboni but it isn't working here.

enter image description here

So it seems Blender is just really arbitrarily annoying and my nodes were right. Tried to replicate the solution provided below but have the front decal wrap around a bit...

enter image description here

enter image description here

I am so pissed at Blender right now.

Edit:

Ok it is working after I had the uvmap overflow the bounds of the image in the vertical direction like in the answer below and still have the decal wrap around a bit on the sides of the Zamboni. Seems like a bug to me.

enter image description here

$\endgroup$
  • $\begingroup$ related: blender.stackexchange.com/questions/46424/… $\endgroup$ – cegaton Oct 27 '17 at 2:11
  • $\begingroup$ If you looked at my nodes you can see I employed the techniques in the link you provided. Also, I'm trying to place two decals with two uvmaps and the link only deals with one. $\endgroup$ – deanresin Oct 27 '17 at 2:29
1
$\begingroup$

Your troubles arise from the fact that UV mapping affects not only the color of the texture but (obiouvsly) also their Alpha channel. When you add a bizzarre (because of UV mapping) alpha with another alpha you get your strange behaviour.

To solve you can edit the "front" UV map so that nothing is overlapping the decal except the faces you want to be textured.

Then take the first texture and color combine it with your blue, so that everything is blue except the grid; then color combine this output with the second texture, so that everything is like the first combination except where you want the second decal.

To better understand nodes behaviour, enable the "node wrangler" addon, and control click over a node: it will instantly create an "emission viewer" shader to read the node's outputs (if you Ctrl click twice on a texture node you'll see its alpha channel).

enter image description here

$\endgroup$
  • $\begingroup$ So your basically saying I can't do what I want to do? I can't have two decals that don't take up 100% of the uvmap they are projected onto? $\endgroup$ – deanresin Oct 27 '17 at 16:50
  • $\begingroup$ I did as you suggested and it didn't work. This program is so buggy. Everytime I switch uvmaps it carries over the image from the previous uvmap. I put screenshots in the OP edit. $\endgroup$ – deanresin Oct 27 '17 at 23:00
  • $\begingroup$ Ok I got it working by having the uvmap overflow the bounds of the image in the vertical direction like you did and still have it wrap around the sides of the Zamboni like I needed. Thanks for your help. I still don't understand AT ALL why this works and the other didn't. $\endgroup$ – deanresin Oct 28 '17 at 0:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.