1
$\begingroup$

Worm gear meshes in Blender Game Engine appear to render without many vertices, and without texture, when running the player. Rendering the same model in the viewport works fine. What is causing this? Is BGE supposed to render all vertices and textures?

Also, text with extruded depth, and texture, gets rendered as 2D text without extrusion or texture. Is this the same problem, or something else?

Blender Game Engine render issues

Update: Also a bug report here: https://developer.blender.org/T53181

$\endgroup$
  • $\begingroup$ Convert (a copy of) the text to mesh. Switch viewport rendering mode to GLSL. Make sure your scene is property lit $\endgroup$ – Duarte Farrajota Ramos Oct 25 '17 at 16:51
  • $\begingroup$ Thank you for the comments. Making a mesh from text gives it depth (extrusion). However this still doesn't get any texture. (Also it seems kind of hacky...) I've already set the Player shading to GLSL if that's what you mean. The scene has lots of light, I don't think that's affecting the visibility. $\endgroup$ – Eagle Gamma Oct 25 '17 at 19:35
  • $\begingroup$ For textures to appear ingame you have to unwrap your meshes and use UV coordinates $\endgroup$ – Duarte Farrajota Ramos Oct 26 '17 at 0:37
  • 1
    $\begingroup$ Visibility: Ensure all face normals of the mesh are pointing outwards. Otherwise you will not see the mesh when seeing the backside. $\endgroup$ – Monster Oct 26 '17 at 5:11
  • $\begingroup$ By disabling backface culling I could get the other faces to show. For textures, I just tried selecting a textured object, edit mode, select all vertices, Mesh > Mesh UV Unwrap... > Unwrap. The texture already had Coordinates: UV. I added "UVMap" to the Map. The object still doesn't get any texture. Are any other actions necessary? $\endgroup$ – Eagle Gamma Oct 27 '17 at 13:10
1
$\begingroup$

The Game Engine by default hides back faces. By disabling backface culling (under the object's properties > material > game settings), I can make it render the faces.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.