0
$\begingroup$

I am following a tutorial and I am working on smoke right now. However, it will not render due to the voxel data not having Density as a source option even though I followed the tutorial. This is my screen:

This is the tutorial's screen:

And yes, I do have a Volume material on the domain object.

$\endgroup$
1
$\begingroup$

The options for that setting were changed in 2.65, which was part of the addition of fire.

In older versions like in the tutorial, only smoke data was used to define the density of the volume, with the addition of fire, there are now two sources. Previous options of Density, Heat, Velocity were changed to Smoke, Flame, Heat, Velocity.

If you are only simulating smoke then use Smoke instead of Density. If you have fire and smoke, then you can create a texture for the fire data and another for the smoke data.

$\endgroup$
  • $\begingroup$ I believe I tried this, but nothing showed up when I tried rendering the image. It was a blank screen, but I have lamps placed and followed the tutorial. $\endgroup$ – JMGbaum Oct 27 '17 at 17:18
  • $\begingroup$ I just tried again, and the same thing happened; when rendered, it is just a black screen. $\endgroup$ – JMGbaum Oct 27 '17 at 22:08
  • $\begingroup$ If the whole render is black then it won't be your smoke texture. This question has a lot of solutions to black renders. Did you set the material density to 0.0 before doing the texture? Where is your camera? can the camera view more than the smoke sim? it may be that your smoke domain fills the camera view - in the viewport change to rendered preview while you know that you can see more than the smoke. $\endgroup$ – sambler Oct 28 '17 at 3:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.