5
$\begingroup$

When I select an object by clicking right or left mouse button, the objects moving with my cursor. I'm new to Blender, not sure if this is a normal default. I tried to disable translate under 3D View, it's not doing anything. How can I disable this behavior?

Thanks.

$\endgroup$
  • $\begingroup$ good question. yes it is normal (click and drag to select and move), but I dont know how to disable it. $\endgroup$ – David Oct 24 '17 at 21:36
  • 3
    $\begingroup$ If I understand correctly it is tweak behaviour (in User prefs > Input switch search to Key-Binding and type "tweak"). To disable uncheck preference for the event in the 3D viewport $\endgroup$ – Mr Zak Oct 24 '17 at 21:47
  • $\begingroup$ Disable tweak doesn't work for me. This is a really counterintuitive default. I'm looking for a setting that when I select an object, it does nothing but selection, and I can enter grab or move mode on my own when I wish to. $\endgroup$ – LLLL Oct 24 '17 at 22:11
  • $\begingroup$ What doesn't work? There is only text description in the question, probably you're facing something else. For tweak disable see blender.stackexchange.com/questions/40150/… $\endgroup$ – Mr Zak Oct 24 '17 at 22:19
  • $\begingroup$ Oh I figured it out. Thank you so much! For anyon looking for the same setting: there are there Translate under 3d View, disable the one following tweak-select-any bar. $\endgroup$ – LLLL Oct 24 '17 at 23:30
1
$\begingroup$

How to stop objects from moving when clicking in 3D view in Blender 2.8:

In Blender 2.79, you could right-select an object, and if you left-clicked anywhere in the viewport, it would only set the 3D cursor position, and the object would NOT move. BUT... in Blender 2.8, the Default NEW transform behavior has changed. If you select an object and then you left-click OUTSIDE the object in the 3D view the object will MOVE. This is highly undesirable behavior, and by default occurs when the "Move", "Rotate", "Scale" or "Transform" tool is selected (not the "Tweak" tool).

Thankfully, this change is easy to disable.

The Transform tool lets you change this behavior interactively:

  • (Open sidebar with N, select Tool > Gizmos > Drag Action. Change from "Move" to "None")

For the "Move", "Rotate", and "Scale" tools":

  • Go to Edit > Preferences > Keymap > 3D View > Object Mode
  • under "3D View Tool: Move" UN-CHECK "Move"
  • under "3D View Tool: Rotate" UN-CHECK "Rotate"
  • under "3D View Tool: Scale" UN-CHECK "Resize"

Example image shown below:

How-to-stop-objects-from-moving-when-clicking-in-3D-view-Blender-2.8

EDIT: The above info will solve the issue of accidentally moving the object when left-clicking outside of it in the 3D view. If you ALSO want to disable accidentally moving the object while clicking on it (as was the case with the original poster, and which also occurred by default in 2.79), then do the following:

How to stop object from moving when clicking on object in Blender 2.8:

  • Go to Edit > Preferences > Keymap > 3D View > 3D View Global
  • UN-CHECK "Move" next to the optional labelled, "Tweak". Leave the other "Move" next to "Keyboard" checked.

How-to-stop-object-from-moving-when-clicking-on-object-Blender-2.8

I hope this info helps someone like me who was confused by this behavior! :-)

EDIT 2: The process is the same for 2.79 users. To disable automatically moving when clicking on an object in 2.79b:

  • Go to File > User Preferences > Input > 3D View > 3D View Global
  • UN-CHECK the "Translate" option next to "Tweak" (leave the "Translate" option checked next to "Keyboard".)

2.79 called it "Translate", 2.81 calls it "Move". :-)

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.