0
$\begingroup$

It's really simple: Shadows won't be cast. I checked the light source to cast shadows, but they aren't cast.

I want a text to cast shadows. I want to place the text on a surface within some video footage.

I already traced the camera motion with tracking and managed to align the text with the markers placed on that surface.

I also don't know how to make the shadow cast appear but not the surface.

I animate the text in the 3D-view and then place the animated scene over the footage over as a strip in the Video Sequence Editor.

Yes there is a surface to catch the shadow, Yes there is a light source.

I tried following some tutorials, but they either have some weird options in them that my blender version doesn't (2.76) or their objects just cast shadows by themselves by default.

$\endgroup$
  • $\begingroup$ I recomend you to use 2.79. It has a casting shadow buttton to speed the process. Just select the surface and click the cast shadow button. $\endgroup$ – LeoNas Oct 23 '17 at 20:15
  • $\begingroup$ I don't know how to update. the Software center says I'm up to date and I don't know how to install freshly from a proper source. I got the latest blender .tar.bz2 $\endgroup$ – Keen Gaze Oct 24 '17 at 14:55
  • $\begingroup$ You must download and install it again. $\endgroup$ – LeoNas Oct 24 '17 at 16:07
  • $\begingroup$ I'm sorry, but I just don't see it. I installed 2.79 and there is no "shadow cast" button. Also, I just noticed that the text as it shows up in the VSE will not assume the colour I set for it under "Material" It will always appear grey. Int he viewport it will appear the correct colour.And the plane that I put BEHIND the text will always appear as if it is in front of it in the rendered view. It will also alway be black, even if I set it to transparent and white, even if I set it to another layer. It will always be black and block the text. $\endgroup$ – Keen Gaze Oct 25 '17 at 11:27
0
$\begingroup$

I recomend you to use 2.79.

First switch to Cycles render.

It has a shadow catcher checker box to speed the process.

Just select the surface and enable the shadow catcher in cyles settings panel in the object tab.

See the image below:

enter image description here

| improve this answer | |
$\endgroup$
  • $\begingroup$ Thank you, it helped. However I am looking for the options that let me define the coarseness of the shadow. Right now it's just a bunch of black pixels. how do I turn it into a homogenous area? Also, a sun-lamp casts a very coarse shadow, should I just use a spotlight instead?, since that has a more satisfyable result. $\endgroup$ – Keen Gaze Oct 25 '17 at 18:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.