2
$\begingroup$

I have a problem with Blender and its animation process, I want to do an animation and to do that I rendered all frames of my project. Textures on all of my frames are visible but when I do the render animation, my textures won't show up. I used UV/Image editor, I applied the materials to the objects and I did the exact same thing for 3 other animation and it has worked on all of them..

Here is a rendered frame where we can see that textures show up. textures on

On this screenshot we can see that there's no textures when I do render the animation but on the right screen we have a view in "Render Mode" which shows us textures... textures off

If anyone can help I'd be very grateful

$\endgroup$
  • 1
    $\begingroup$ Could you upload your blend file if possible? pasteall.org/blend $\endgroup$ – Vader May 11 '14 at 14:34
  • $\begingroup$ Here it is dropbox.com/s/n0iqdwr8g7dacls/Building_courbe2.blend . I couldn't upload it on pasteall because my file is too big . $\endgroup$ – primo May 11 '14 at 14:58
  • 1
    $\begingroup$ I don't know what to tell you. For me both f12 (render) and ctrl + f12 (render animation) work just fine. $\endgroup$ – Vader May 11 '14 at 16:16
  • $\begingroup$ Yes for me too but if you use the video sequence editor by using all the frames you have rendered, textures won't show up. That's my problem :/ $\endgroup$ – primo May 11 '14 at 16:26
  • $\begingroup$ You should save out the images and than after rendering them you should load them back in. $\endgroup$ – Vader May 11 '14 at 17:21
1
$\begingroup$

This is because you have a scene strip above your rendered image sequence, which will display the same thing as the default viewport in solid shading (no textures), unless you set it to something else like textured or rendered (rendered will be very slow because it has to render each frame. You also have to disable openGL preview for rendered to work):

enter image description here

However, assuming the image sequence below it is the rendered animation, then you can just remove the scene strip.

| improve this answer | |
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.