0
$\begingroup$

I was working on a video in which camera moves along with the train object, all animation was going well. I am not sure what key I accidentally pressed and my camera is not showing in the view any more. Where as camera is still visible in the outliner.

How can I get my camera back?

Its easy to just delete the camera and create a new one but in this case I will lose my animation already applied on camera.

enter image description here

$\endgroup$
  • $\begingroup$ Please, add a screenshot, or upload a file $\endgroup$ – Crantisz Oct 22 '17 at 10:40
  • $\begingroup$ Is your camera on visible layer? $\endgroup$ – Crantisz Oct 22 '17 at 10:43
  • $\begingroup$ How may I check that ? $\endgroup$ – Blender For You Oct 22 '17 at 10:44
  • $\begingroup$ Select camera in outliner and find where is the yellow dot in the layers buttons $\endgroup$ – Crantisz Oct 22 '17 at 10:46
  • $\begingroup$ Wooww... I got it, so it was moved to a different layer, Thank you very much Can you please post it as an answer? $\endgroup$ – Blender For You Oct 22 '17 at 10:50
1
$\begingroup$

Check that you camera is not hidden and it is on visible layer.

And also you can try this:

Its easy to just delete the camera and create a new one but in this case I will lose my animation already applied on camera.

You will not lose animation because block with animation data will not delete with object.

So you can do this:

Open dope sheet in action editor mode

enter image description here

Find name of camera animation data:

enter image description here

When delete camera and create new one. And select animation data of your deleted camera:

enter image description here

$\endgroup$
  • $\begingroup$ Great, it make my day, Thank you very much :), Have a nice time. $\endgroup$ – Blender For You Oct 22 '17 at 10:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.