1
$\begingroup$

Here's a link to my files and texture images

For some reason certain parts of my mesh are using their normal maps for texturing/color instead of the texture images I have selected for color with their respective blender materials. The result is shown below:

enter image description here

You can see that the hair and fins on the arm are affected. Their colors should be closer to this:

enter image description here

$\endgroup$
  • $\begingroup$ Make sure that those parts of the mesh have the correct material assigned to them $\endgroup$ – cegaton Oct 20 '17 at 20:03
  • $\begingroup$ Just double checked that and they do have the desired materials assigned to them. $\endgroup$ – Tyler Oct 20 '17 at 20:04
3
$\begingroup$

Than multitexture setting enabled, faces displays last assigned texture in UV-image editor.

Switch to GLSL mode, in this mode faces tries to display close to material settings:

enter image description here

However, when it is set to "solid" I still see the normal map as opposed to the proper texture.

If you have textures in solid mode, uncheck textures solid:

enter image description here

$\endgroup$
  • $\begingroup$ That seems to work for when "viewport shading" is set to "texture." However, when it is set to "solid" I still see the normal map as opposed to the proper texture. $\endgroup$ – Tyler Oct 20 '17 at 20:07
  • $\begingroup$ Hmm, seems that it must have been a weird visual glitch, because after deleting and recreating the texture image the hair now displays correctly in all shading modes for the viewport. $\endgroup$ – Tyler Oct 20 '17 at 20:16
  • 1
    $\begingroup$ Uncheck also "textured solid" option $\endgroup$ – Crantisz Oct 20 '17 at 20:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.