4
$\begingroup$

The lower/larger cube is "shiny." The smaller cube on top is not. Materials do not seem to be making a difference. Normals appear to be facing outward as well. What could be causing this? enter image description here

$\endgroup$
1
  • $\begingroup$ Cubes at the bottom have shading set to smooth and maybe some custom normals also (doubtly). $\endgroup$
    – cgslav
    Commented Oct 20, 2017 at 8:44

2 Answers 2

10
$\begingroup$

Smooth Shading W -> Shade Smoth (in Edit Mode)

enter image description here

Most objects are represented by polygons and truly curved objects are often approximated by polygon meshes. When rendering images, you may notice that these polygons appear as a series of small, flat faces.

enter image description here

Smooth Shading tries to interpolate surface of model so you can't see faces. Usually we want our objects to look nice and smooth, but sometimes this makes this ugly artifacts than it tries to smooth too large angles between faces. Like in your case - 90 degrees.

So, turn off smooth shading, or, if you want to use it, set auto smooth option: enter image description here

$\endgroup$
1
  • $\begingroup$ I ran into that once a while back and ended up starting over. Can't believe it was such a simple thing. $\endgroup$
    – Omegacron
    Commented Oct 20, 2017 at 13:51
-3
$\begingroup$

Well there is an other form of shininess that has not to do with smooth shading. In other words. One object is very shiny and a copy is not but both are smoth shaded!

$\endgroup$
1
  • $\begingroup$ Hello and welcome! Please be so kind and try to be more precise in your explanation. As this answer is currently worded, it is unfortunately not very helpful, because you do not explain here what the problem could be and how to solve it. Thank you! $\endgroup$
    – quellenform
    Commented Dec 30, 2022 at 1:06

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .