0
$\begingroup$

I'm trying to make work the add-on called "Radiant Rig XL" with the character that I usually use to learn blender. I don't why,but it does not work,like you can see from this screenshot.

and you can find the character that I'm working with here.

I sent an email to the author of the script and he replied to me telling :

"You have a script attached which interferes with Rigify (rig_ui.py). Radiant Rig depends upon Rigify as stated in the instructions. If you are changing Rigify, I can't predict what will happen"

I disabled the option called "auto run python scripts" from the user preferences panel because I wanted to disable the "rig_ui.py" script,but it didn't work. Can someone of you be more specific ? How can I disable the interfering script ? What is this ? I don't know anything about it. Thanks.

$\endgroup$
1
$\begingroup$

Here were the steps I took to diagnose the problem you are having:

1) When I opened your file, I saw the error message "Auto-run disabled: Text 'rig_ui.py'" (see screen shot 1) Screen Shot 1

2) Near the Help item at the top, I switched the layout from 'gp2' to 'Scripting' (see screen shot 2) Screen Shot 2

3) I saw a script which is designed to modify the rigify plugin. Radiant Rig depends upon Rigify as stated in the instructions. If you are changing Rigify, I can't predict what will happen. I did not have time in the morning to debug the rig_ui.py attached to your file. (see screen shot 3)

Screen Shot 3

4) I selected the figure in your file and merged all the parts into one object (CTRL+J)

5) I exported your object.

6) I created a blank blender file; I was able to import the exported figure into this new file.

7) I ran my script and it fitted the mesh better.

Please follow those exact steps.

$\endgroup$
  • $\begingroup$ 4colorgrapix said : "I've found an error with Blender 2.79. That was why I could not replicate your error. Try the version 4.1 of the addon". $\endgroup$ – Marietto Oct 19 '17 at 17:23
  • $\begingroup$ Please quote what I actually wrote: > I've found an error with Blender 2.79. That was why I could not > replicate your error. I've updated my code for that version. You'll > get an official email through Gumroad with the update. It gives other readers a false impression of what I communicated. I don't appreciate having my words changed in a public discussion. $\endgroup$ – 4colorgrafix Oct 20 '17 at 17:17
  • $\begingroup$ but man,I haven't changed your words fraudulently,I made a summary. $\endgroup$ – Marietto Oct 21 '17 at 17:57
  • $\begingroup$ I apologize for my reaction. $\endgroup$ – 4colorgrafix Oct 22 '17 at 18:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.