I am trying to make a stationary emission object (placed in between two other objects) appear and disappear to create the illusion of a flare that comes on and shuts off quickly. The emission object is 2D text and a copy of 3D text on top. The emission object has two nodes: emission and transparency connected to a mix shader. When I manipulate the 'factor' in the mix shader, the emission object appears and disappears like it is supposed to. However, when I hover the cursor over the factor entry box and press 'I' to create a keyframe it does not turn yellow to indicate it has taken and no keyframe is created. I get the same result when I hover and press 'I' in the materials tab in the properties area on the right. What am I missing?! (By way of disclosure, I'm a relative newbie to Blender and animation in general.)

  • $\begingroup$ Am I correct in assuming that you are trying to make an emissive object disappear from the scene? If so, I will be happy to assist you with that! $\endgroup$ – HappyBlenderUser Oct 17 '17 at 22:22
  • $\begingroup$ possibly related: blender.stackexchange.com/questions/42593/… $\endgroup$ – user1853 Oct 17 '17 at 22:38
  • $\begingroup$ What happens when you right click the property and choose Insert Keyframe option? $\endgroup$ – Duarte Farrajota Ramos Oct 17 '17 at 22:39
  • $\begingroup$ Thx YusaMac205. It's like a bulb that turns on only for a few seconds toward the end of the scene, lights up the objects around it, and turns off. The emission object is not visible in any case, because it's hidden behind another 3D text object. It's only purpose is to flare up for a few seconds, create a glare behind the 3D text object, and then fade out. I hope I'm explaining this properly. $\endgroup$ – Jeet Oct 17 '17 at 22:43
  • $\begingroup$ Maybe this one may help? blender.stackexchange.com/questions/81751/… $\endgroup$ – Paul Gonet Oct 17 '17 at 23:19

You can key the visibility of the object by hovering in the outliner over the render restrict symbol (camera symbol) next to your object and pressing I to add a keyframe. Then create a invisible key on the first frame, a visible key on the second key and again a visible on the third. That should give you the flash effect you want when you render it, but it will only show in viewport if you also key the viewport visibility (but I am currently not sure if that's also possible...)


I think the guide to setting node keyframes will answer your question

Step 1.

Right click on the specified value in the node editor.

Right click object

Step 2.

Click Insert keyframe enter image description here

  • 1
    $\begingroup$ Yup, this will work: have a Mix shader mixing between the Emission (visible) and Transparent (invisible) shaders, and animate its mix factor between 1 (fully visible) and 0 (fully invisible). Don’t forget to increase the number of transparent bounces in the Cycles render settings, else the object may not be fully invisible! $\endgroup$ – Lawrence D'Oliveiro Oct 18 '17 at 4:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.