I been having this problem for years and been looking up tutorials and videos and can see people painting away seams super easily. I some times get seams that i can clone brush or texture over without any problems but in the same model i will have seams that will never go away. Pixel bleed has no effect on these seams.

The answer here doesn't work on my models. I also have that same potato file and my texture will paint over the potato seams but not the models i made.

How to remove/blur the texture seam?

Or in some of my other projects, i can't paint away a single seam using the clone brush or texture paint method (blending).

Doesn't matter how many times i re-mark and unwrap (i even tried smart uv unwrap). The normals of my object are all facing out, it's smoothed. The model textures i work on are 1024x1024 or bigger. Even smeared black, grey and white colors can't cover these seams, pixel bleed does nothing. I tried re-calculating normals and it didn't help either.

I make the model, apply a single material and generate a blank uv texture. I then mark seams as efficiently as possible and then unwrap. I go into texture paint and set the bleed to 2,4 or 6 but it rarely works. I have tried setting it higher but the results are the same.

I use seamless textures and paint over it, works on the potato file but a lot of my models refuse to let me clone brush over the seams. Some of my models have mixed results but ultimately they all have seams.

I can upload some pictures if needed.

Snak 1 Seam Snak 2 UV Seamless Wall (This last one is rare for me, even with basic objects)

  • 3
    $\begingroup$ Yes, please include screen shots of what you are seeing and the uv image editor with the image in view. $\endgroup$ – Craig D Jones Oct 17 '17 at 13:00
  • $\begingroup$ Here's my deviant art if you need more screen shots of models and textures that i messed up some how, i hate seams. modtyrant.deviantart.com $\endgroup$ – modtyrant Oct 17 '17 at 19:29
  • 1
    $\begingroup$ Pics are kind of dark, but I see that the unwrap there doesn't give much real estate to the faces. That aside, have you tried painting only in the 3d view, and what happens when you paint a base color first around the edges of your island in the UV Image Editor there? By trying to paint the seams out, what are your actual steps? Are you placing the cursor across the other side and using the clone tool set to a moderate strength? $\endgroup$ – Craig D Jones Oct 17 '17 at 20:36
  • $\begingroup$ I am just trying to blurr the seam using the texture brush, exactly how it looks on the bottom of the snake. You can see the two textures over lapping on the bottom and there isn't a seam. I all ways paint directly on the model either using a texture brush (loaded with an image in tile mode) or using clone brush to clean up the texture manually up close, grabbing colors, smearing etc. However it does not look good and is too slow of a process. I prefer just to paint the texture right over the seams in 3d view. $\endgroup$ – modtyrant Oct 17 '17 at 20:49
  • $\begingroup$ Oh and base colors bleed out horizontally (if the seam is horizontal) from strokes and dabs. A cloudy grey texture won't cover the seam either or if i made a uniform smear across it. Painting on UV in the image editor lines up worse than in 3d mode. $\endgroup$ – modtyrant Oct 17 '17 at 20:55

Are you using Subsurf? If you are, do you have Subdivide UVs checked? Apparently this can cause seams to be exposed. https://developer.blender.org/T26426 Try unchecking Subdivide UVs and see if it helps.

Also adding loops at the edges might help: https://blenderartists.org/forum/archive/index.php/t-343226.html

| improve this answer | |
  • $\begingroup$ I will try it and thanks for the response. I just tried a smart UV unwrap and had it stretch to bounds and that same seam from the screen shot is now paint-able but my UVs are crap because smart UV unwrap isn't the greatest option. So now other parts have seams lol. I don't know what's going on this UV stuff is glitch-y. Oh and i usually don't use smooth modifiers. $\endgroup$ – modtyrant Oct 18 '17 at 8:46

It appears blender's pixel bleed doesn't work well with textures OF 1024x1024 or lower. I am not entirely sure that is the problem but by increasing the resolution of the texture and using subdivision surface modifier, it greatly reduces seaming when using a bleed value between 2 & 4.

Lower resolution textures (1024x1024 and lower) cause the bleed effect to be VERY prominent and doesn't cover the seam but rather makes more seams. Lowering bleed to 1 or 2 pixels will either refuse to paint over the seam OR you just get really bad vertical or horizontal bleeding.

This problem doesn't occur if your UVs are perfectly aligned like a box BUT the more complicated the object the more of an issue this becomes for low resolution textures.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.