1
$\begingroup$

I was trying to apply a material to the object but it does not show up in Solid mode when I switch to Material mode the color shows up.

Solid Mode: Solid Mode

Material Mode: Material Mode

$\endgroup$
  • $\begingroup$ If you wish to use cycles materials on your object, you can't expect to see them in the viewport, except in "rendered" mode (next major version 2.8 will likely hugely improve this). $\endgroup$ – m.ardito Oct 17 '17 at 7:35
2
$\begingroup$

Scroll to the very bottom of the Materials panel, go to Settings and use the Viewport Color. ;)

$\endgroup$
  • $\begingroup$ Also make sure you do that for each individual material you wish to see :) $\endgroup$ – NBoss Oct 17 '17 at 6:12
  • 2
    $\begingroup$ but keep in mind that viewport color is not the one rendered by cycles... it just helps fir a fast viewport look. $\endgroup$ – m.ardito Oct 17 '17 at 6:38
1
$\begingroup$

This is not an issue, its the default behavior of the blender, if you want to see the materials in solid mode you may use the material tab to drag and drop same color on the Viewport color just under the settings. As shown below:

Drag and Drop:

enter image description here

Result: enter image description here

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.