0
$\begingroup$

I'm currently making a tree with branches and leaves etc., but for some reason, whenever I go from solid to rendering mode the textures that I applied come out extremely dark, which (I think) is caused by the lack of lighting. Can someone possibly help me? Here are some screenshots.

Here is the texture I applied to the trunk of the tree:

enter image description here

Here is the result after rendering:

enter image description here

Here are the nodes that I'm using:

enter image description here

$\endgroup$
3
  • 1
    $\begingroup$ Don't really get your problem. If you don't have any lightning, it will only be lighted by the world default environment color which is a dark grey, hence the dark render. $\endgroup$
    – sekce
    Oct 15, 2017 at 11:11
  • $\begingroup$ so how would I go about adding this? it seems that everytime i add a lamp in solid mode, then go to rendering mode, the lamp disappears $\endgroup$ Oct 15, 2017 at 11:20
  • $\begingroup$ Add HDRI image and try $\endgroup$
    – atek
    Oct 15, 2017 at 11:44

2 Answers 2

3
$\begingroup$

With the sun you have added to your scene should be enough to at least see your scene lit. The thing is that you have it turned off on the viewport. Turn it on by clicking the eye icon right next to it in the Outliner.

enter image description here

$\endgroup$
1
  • $\begingroup$ yeah, this fixed it i think. thanks dude. $\endgroup$ Oct 17, 2017 at 17:33
1
$\begingroup$

Yes, that is how 'Rendered' mode with Cycles works, it looks almost exactly the same as if you were hitting F12 (or the 'Render' button). You can either not use 'Rendered' mode, add lights to the scene or enable ambient occlusion like so:

enter image description here

$\endgroup$
1
  • $\begingroup$ Ah, you sir, have saved hours of my time. much appreciated $\endgroup$ Oct 15, 2017 at 11:41

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .