3
$\begingroup$

Most of the bee is animated, specifically the wings, each flap is around 3 frames so there should motion blur happening at least with the wings.

I've attached the pertinent screen shots of settings as reference.

I've also tried rigging a primitive object with bones and animating it next to the bee with the same settings which does render with motion blur.

enter image description here enter image description here enter image description here

$\endgroup$
3
  • $\begingroup$ I don't think that rigged animation gets motion blur at the moment only over all object motion. Perhaps if the wings were separate objects? Also with such extreme blur, its better to fake it. That's what happens with helicopter blades and plane propellers. Maybe a volumetric shape would work and render quicker? Only issue would be lack of glint from surface of wings in a volume (no reflections) $\endgroup$
    – 3pointedit
    Oct 12, 2017 at 4:45
  • $\begingroup$ I've tried it with another mesh it does render motion blur on deformations, just not on this mesh. $\endgroup$
    – o88
    Oct 12, 2017 at 17:17
  • $\begingroup$ Attached a primitive example above, made in the same file. $\endgroup$
    – o88
    Oct 12, 2017 at 17:21

3 Answers 3

1
$\begingroup$

motion blur in blender is calculated based on the previous frame positions. so blender should load the scene for 2 frames to calculate motion blur, essentially to calculate motion. Adaptive subdivision is a heavy process and i believe happens only on the frame you are rendering so it has no data for the previous frame.

$\endgroup$
4
$\begingroup$

As of 2.79, Cycles does not support adaptive (micro) subdivision and deformation blur on the same mesh. You should uncheck "adaptive" on the subdivision surface modifier if you need deformation blur.

See this documentation page from the main developer of this feature: https://wiki.blender.org/index.php/User:Maiself/Micropolygon_Displacement

$\endgroup$
1
  • $\begingroup$ A reference would make this answer much stronger... $\endgroup$
    – JakeD
    Apr 24, 2018 at 2:52
0
$\begingroup$

I would suggest to change Shutter type to None. I'm not sure why, but from my experience, Top-Bottom doesn't give blur with motion based on rig bones movement (like flapping wings f.ex.).

$\endgroup$
5
  • $\begingroup$ Forgot I turned that on, was an attempt to get a result when None was producing none lol, still no go though $\endgroup$
    – o88
    Oct 12, 2017 at 17:12
  • $\begingroup$ Weird. Why would one object produce blur and other not in the same circumstances? Are the origins of the armature and fly there or in center of the scene (0,0,0)? $\endgroup$
    – Mzidare
    Oct 12, 2017 at 18:45
  • 1
    $\begingroup$ I got it to go by turning adaptive subdivision off in the modifier stack, is that not supported? $\endgroup$
    – o88
    Oct 12, 2017 at 20:51
  • $\begingroup$ You should probably answer your own question with your solution so that others can benefit, sometimes these replies are hidden from view. $\endgroup$
    – 3pointedit
    Oct 13, 2017 at 0:41
  • $\begingroup$ Yeah, you definitely should place your solution here as an answer. It's pretty unusual problem, and knowing it surely will be useful for someone else too. $\endgroup$
    – Mzidare
    Oct 13, 2017 at 11:24

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .