9
$\begingroup$

I've been modeling a hermit crab and I don't know why but some areas of the mesh are really dark on some spots, like the legs and the claws. enter image description here

I hope you can help me fix it.

$\endgroup$
  • $\begingroup$ Try to select all mesh in Edit Mode and press Ctrl+N to Make Normals Consistent... did it help? $\endgroup$ – Jan Kadeřábek Oct 8 '17 at 20:53
  • $\begingroup$ I've already try that it didn't work $\endgroup$ – Sigma17 Oct 8 '17 at 20:58
  • $\begingroup$ can you upload your .blend via this link so I can take a look at it? blend-exchange.giantcowfilms.com $\endgroup$ – Jan Kadeřábek Oct 8 '17 at 21:10
11
$\begingroup$

This is called shadow terminator artifact and happens with some render engines on low poly meshes. It is a limitation that Cycles has, devs know about it.

Bug T37814: Artifacts in Cycles render for lowpoly models

enter image description here

enter image description here

The solution is to increase the polygon count.

The black on the silhouette is another kind of artifacts you might encounter called rejection sampling - also does go away with polycount.

You can change also the shading method. Your whole surface is set to smooth - it is interpolating the surface normals making shadows where there probably shouldn't be. You may want to turn on Auto-smooth or set some sharp edges:

How to smooth shade an object while retaining hard edges?

$\endgroup$
0
$\begingroup$

Also, when rendering with Eevee, check if Contact Shadows option for your Light source is on. This option tends to give similar edgy-looking shadows in render, even with Subdivision Surface.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.