Is there a way to render an object with a subdivision surface modifier with a wireframe which is the original geometry as well as the wires that make the subdivision surface?

enter image description here

This wireframe here is curved. What if there was displayed the straight wireframe. The wires that make are made by the subdivision surface. Thats what I want to achieve. How to do it?

What I mean is - How to render the curved wireframe (which is the original geometry with the straight wireframe (which is the wireframe the is made by the subdivision surface)?

  • $\begingroup$ Are you saying you want the head to be rendered with the wireframe showing? If so, that is possible. $\endgroup$ Commented May 7, 2014 at 2:23
  • 1
    $\begingroup$ @ThomBlairIII I think he wants to render the high-poly head, with a quasi-low-poly wireframe; the wireframe should look pretty much like the edges of the low-poly head, but with nice curves like the high-poly head. $\endgroup$
    – ajwood
    Commented May 7, 2014 at 13:20
  • $\begingroup$ Related: blender.stackexchange.com/q/2372/599 $\endgroup$
    – gandalf3
    Commented May 10, 2014 at 23:52

1 Answer 1


Rendering curved wireframes:

Blender Internal

You can either use freestyle or a wireframe material, see Rendering with wireframe.

If you use a wireframe material, make sure Optimal display is enabled on the modifier, otherwise all the edges generated by the subserf will be rendered as wires (they won't be curved).

enter image description here


To do this in cycles, you could use two scenes, one for the cycles render and another to render the wireframe with one of the BI techniques.

To get a BI wireframe material to render with a transparent background (for combining with a cycles render), just set the second material to Masking alpha:

enter image description here

And set Alpha to Transparent in Render settings > Shading:

enter image description here

Original answer

OP clarified the question, making this no longer relevant. As far as I can tell, that is..

If you want to do this in the viewport/opengl render, just enable Draw All edges in Properties > Object > Display:

enter image description here

And make sure Optimal display is disabled in the subserf modifier:

enter image description here


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .