0
$\begingroup$

--Conditions;

I am unable to use a smaller resolution than 4K due to an odd hardware issue.

I am using Windows 10.

Issue only appears is select mouse environments (not limited to Blender.)

Windows UI scalling is applied.

The 'scaling override' in 'compatibility' has already been toggled and experimented with.

Blender's internal DPI scaling does not solve the issue.

Blender's 'Big Cursor' option does not solve the issue.

--The problem;

Due to an odd hardware limitation I'm forced to use an extreme DPI that seems to be generally poorly supported. As a result the normally easily distinguishable cursor in edit mode completely fades into mesh when it hovers over it. I have all Windows tools for UI scaling applied, which works for the most part. But in certain conditions, some elements reverse back to their true 4k resolution, among which the Blender Edit mode cursor.

https://www.dropbox.com/s/w1bkrzzt9vdnv9r/HollowCursor.gif?dl=0

Are there any manual ways to increase the size or its colours to be more visible? Other potential solutions would of course also be appreciated. I'm a bit at wits end with this issue.

Thank you in advance.

$\endgroup$
  • 2
    $\begingroup$ Windows has ease of access settings that can change cursor size and colour. $\endgroup$ – sambler Oct 5 '17 at 6:37
2
$\begingroup$

This is the culprit:

wm_cursors.c:
#ifdef _WIN32
/* the default win32 cross cursor is barely visible,
* only 1 pixel thick, use another one instead */
if (curs == CURSOR_EDIT)
curs = BC_CROSSCURSOR;
#else

I downloaded the source code and compiled blender myself to remove this. This way it uses windows's default precision cursor which you can change to whatever you want.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.