1
$\begingroup$

Hey fellow Blenderers,

I created an asteroid mesh, bisect cut it 3 times (for each axis) to get 8 parts out of it. I need these parts later for animation purposes. After cutting and separating these parts into individual meshes I remerged them, because I only need the parts separated from each other (no connecting faces). The issue I discover now is a different normal on the vertices at the cutting edges as you can see on the image. I think it's normal behavior? Idk. So my question is either "how can I fix the normals to appear the same" or "how can I cut the mesh in parts without influencing the normals"?

enter image description here

Thanks so far

$\endgroup$
  • 1
    $\begingroup$ Hard to tell what is going on from this image alone, but sounds like you ended up with very bad topology and ngons after you blindly cut your geometry with a plane. $\endgroup$ – Duarte Farrajota Ramos Oct 4 '17 at 0:56
1
$\begingroup$

First off: Yes this is normal behaviour.

When you split a parts off of a mesh, then you get more vertices. Those new vertices have their own normals and the normals of the old vertices change a little.

Why? Because vertex normals are calculated by averaging the normal for all adjacent faces of a vertex.

You can see the change of the vertex normals in this image: change of vertex normals after splitting a mesh

You use tangent space normal maps so you'll have a problem in your game engine, because tangent space normal maps change the normals of your mesh based on the existing normals. Maybe it still looks ok in your engine, the difference of the normals is not that big, then just leave it as it is.

If it doesn't look ok and you can see a sharp edge, then you have these options (that I know of):

  1. Rebake the normal map to the new split mesh (that's probably going to be complicated because projections are also based on mesh normals ...)
  2. Use the Normal Edit Modifier and create a vertex group and an object to point the normals to for every single vertex you need to adjust (hopefully your exporter accepts the info correctly, because applying the modifier doesn't work and you will not see any changes on the normals in edit mode)
  3. Use the Data Transfer Modifier to transfer the normals from your old, unsplit mesh to your new split mesh (check "Face Corner Data" and "Custom Normals" and hope that your exporter accepts the info correctly, because applying the modifier doesn't work and you will not see any changes on the normals in edit mode)

I know that Maya allows manual editing of individual vertex normals and 3ds max has smoothing groups which is a weird way to almost set vertex normals manually, but not quite (and it wouldn't work in your case).

Sorry to leave you with bad news. Good luck!

$\endgroup$
0
$\begingroup$

Try to go into Edit Mode, select a geometry you want to "fix" and press CtrlN to Make Normals Consistent. That should fix it.

You can also try to Recalculate Normals in the 3D view, N to open the left panel > Shading/UVs tab.

enter image description here

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.