0
$\begingroup$

For some reason whenever I press Ctrl+P and choose the option "With Automatic Weights" so I can weight my model's meshes, Blender in some areas only weighs the body (leg bone only moving the leg but not the dress), while in others it weights more than it should (arm bone moves the whole shirt). What is causing this?

https://i.imgur.com/oCiRpDj.png

$\endgroup$
3
  • $\begingroup$ Is the clothing a separate object? $\endgroup$ – pie75 Oct 2 '17 at 14:34
  • $\begingroup$ Please add more details in your question, we cant guess the issue, can you please upload some images $\endgroup$ – Blender For You Oct 2 '17 at 14:38
  • $\begingroup$ Both the clothing and the character's body are together in object mode, but separated in edit mode (don't know why that's happening either). i.imgur.com/oCiRpDj.png / i.imgur.com/YoVZOWs.png $\endgroup$ – Leonardo Ricci Oct 2 '17 at 14:43
0
$\begingroup$

From the images you've provided it shows, that the body and cloths are different meshes. Bones would have to be close to/touching/pertruding cloth meshes to provide correct-ish automatic weights. I don't recommend this approach though, cause it will never give totally satisfactory outcome. To get it done properly you have to join parts of the body (hends, neck, feet) with the cloths. In my opinion though, better solution is to separate cloths and shoes meshes from the model and parent them separately to the same armature as body, then add mask modifier to the body to hide parts of it, that are hidden by the cloth, but can protrude during animation.

$\endgroup$
2
  • $\begingroup$ Ok, so I've separated my model's clothes from their body and now it's been weighted properly. But I still don't know to add the mask modifier as you mentioned. So far all I've tried is select the body and add the modifier, but I still don't know what to really do. $\endgroup$ – Leonardo Ricci Oct 2 '17 at 15:45
  • $\begingroup$ Create vertex group "mask" for body mesh. Select hands neck, head, feet vertices in edit mode and with "mask" group selected press "Assign". Then go to the Mask Modifier settings and under "Vertex Group" choose "mask". Basically Mask Modifier shows everything, that is assigned to the choosen vertex group and hides everything else, so if something is not showing, that should, select it's vertices and assign to the "mask" group. $\endgroup$ – Mzidare Oct 2 '17 at 16:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.