3
$\begingroup$

I have an UDIM texture.

When I load my model in ZBrush, the UVs are stacked on top of each other, and that makes painting it really difficult:

enter image description here

I would therefore like to "un-stack" it in Blender.

It should look like this: enter image description here

Could anybody please tell me how to do?

I have uploaded the Blend file here: (contains nudity)
http://pasteall.org/blend/index.php?id=47958

$\endgroup$
4
$\begingroup$

If you still want to do this after reading pie75's answer, the MultiEdit Addon might come in handy.

  1. Select all objects, go to MultiEditMode.
  2. Then select a face, press Shift+G -> Image
  3. Move the UVs in UV Editor by pressing G X 256 (in this case, other value might be needed for other cases).
  4. Hide the faces with H and proceed with another yet unhidden face, but this time move for the double amount.
  5. When all UVs are moved, exit MultiEditMode and you are done.

Blenderman example (without hiding faces): enter image description here

|improve this answer|||||
$\endgroup$
  • $\begingroup$ I installed MultiEdit and I tried to do as suggest but something always goes wrong. Would you be willing to show it to me for two face so that I can see the workflow? $\endgroup$ – tmighty Oct 2 '17 at 16:14
  • 1
    $\begingroup$ See my edit. Hiding faces is not necessary but is helpful so that one doesn't forget any textures. $\endgroup$ – Dimali Oct 2 '17 at 17:25
3
$\begingroup$

UV Maps automatically wrap, in all my experiences. Vertex points with a value greater than 1 wrap back to past 0, and lower than 0 wraps back to past 1.

The solution, then, is to make sure all your UV vertices stay within the bounds of the UV map(which is 0-1). Scale your UV's down, and move them into positions within the UV space.

Other than that, you could use multiple materials, or multiple UV maps. Add a new material from the material tab in your object, or add a new UV map slot under the mesh tab.

|improve this answer|||||
$\endgroup$
  • $\begingroup$ Thank you. Did you take a look at my Blend file? I'm not sure, but I think the model already has multiple materials. $\endgroup$ – tmighty Oct 2 '17 at 0:08
  • $\begingroup$ Unfortunately, I did not, sorry. It was 2AM and I was about to collapse. In fact, I did collapse 20-30 minutes later. Your model does have multiple Materials, but since all the objects are separated, and each of their materials have an index of 1, I feel that may cause a bunch of problems when importing them as a single thing. Then again, I don't use ZBrush.. $\endgroup$ – pie75 Oct 2 '17 at 9:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.