When I try to render with the Cycles render on my GPU I'll get a message which says that my CUDA compilation failed and I get this error in the console;

Compiling CUDA kernel ...
"nvcc" -arch=sm_61 --cubin "/usr/share/blender/scripts/addons/cycles/kernel/kernels/cuda/kernel.cu" -o "/home/nils/.config/blender/2.78/cache/cycles_kernel_sm61_E317D1655098C1EB89BEC29AC2C7B15D.cubin" -m64 --ptxas-options="-v" --use_fast_math -DNVCC -D__KERNEL_CUDA_VERSION__=80 -I"/usr/share/blender/scripts/addons/cycles/kernel" 
ERROR: No supported gcc/g++ host compiler found, but clang-3.8 is available.
       Use 'nvcc -ccbin clang-3.8' to use that instead.
CUDA kernel compilation failed, see console for details.

Graphics card: Nvida Geforce GTX 1050ti (gigabyte= Processor: Intel core i5 6400 (4x2.7GHz) 16gb ddr3l 1600

I have already installed gcc, g++, clang, and all Nvida drivers.


With *buntu 20.04, modify the blender.desktop launcher to:

CYCLES_CUDA_EXTRA_CFLAGS="-ccbin clang-8" blender

As per the Blender web page as of 07-April-2020, Blender is not compatible with gcc 4.7 or higher.

The above command will launch Blender with compiler settings compatible with 20.04. The 1st GPU render requires a few minutes to compile the CUDA renderer, but afterwards renders will run immediately. Nvidia 1080 CUDA rendering was 6× faster than my old 4771 CPU alone.

| improve this answer | |
  • $\begingroup$ For me on Debian Bullseye I needed clang-6.0 but otherwise perfect. $\endgroup$ – Victor Klos Jun 6 at 20:22

I'm having exactly the same issue. After seeing the error message, and the posts here, here, and here, I think the problem was caused by nvcc not supporting the newer compiler versions installed on Debian by default. For me, the problem was solved by using the Blender 2.79 release candidate instead. I think it may also be solved by installing older versions of the compiler.

| improve this answer | |

@TheCommuter is right. In addition, clang-8 might need to be installed. This is the noob-proof guide:

  1. Stop blender if it is running
  2. Locate your .desktop file. try:


  3. open a terminal and move the file temporarily:

    sudo mv /usr/share/applications/blender.desktop ~

  4. Edit the desktop file.

    sudo gedit ~/blender.desktop

    Change te Exec line to:

    Exec=env CYCLES_CUDA_EXTRA_CFLAGS="-ccbin clang-8" blender %f

  5. Make sure clang-8 is installed:

    sudo apt install -y clang-8

  6. Install your modified .desktop file

    sudo desktop-file-install ~/blender.desktop

Blender should now be available in your Applications, and work with Cycles (GPU)

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.