0
$\begingroup$

Does anybody know why i get this flat-shading when i add a normal map even though i enabled smooth-shading? the moment i remove the normal map it goes back to smooth.

enter image description here

Thanks for the help! :)

$\endgroup$
  • 1
    $\begingroup$ That's curious. Try to set your "image texture" node to "non color data". hope it helps. cheers :) $\endgroup$ – hernandoramos Sep 25 '17 at 21:41
  • 1
    $\begingroup$ Try selecting your Normal Map in the UV Editor to see how things are arranged. Your Normal Map has a lot of straight lines in it that may be causing the "Lines" on your barrel (Not the shading). Also the Image Texture Node for you Normal Map should be set to Non Color Data. $\endgroup$ – Dontwalk Sep 25 '17 at 21:50
  • $\begingroup$ It might help if you upload you .blend file by using blend-exchange.giantcowfilms.com Be sure to "Pack" the Normal Map into the file. $\endgroup$ – Dontwalk Sep 25 '17 at 21:53
  • 1
    $\begingroup$ for sure, check if all faces are set too smooth shading. If you using pie menu, is very easy randomly set selected faces to flat pressing TAB and move mouse to right-down direction. $\endgroup$ – Shubol3D Sep 25 '17 at 22:06
  • $\begingroup$ Thanks for your efforts so far. i added the blend-file and hope it helps. $\endgroup$ – Dman Sep 26 '17 at 16:18
3
$\begingroup$

The problem was, as many people suggested, the Image node for the normal map was not set to non-color data:

$\endgroup$
  • $\begingroup$ Great, many thanks to you and the other users! $\endgroup$ – Dman Sep 26 '17 at 17:06
  • $\begingroup$ If you stumble upon this in Blender 2.8 then you may also touch the "Strenght:" Parameter in the Nodes.... Drove me crazy that the "Non Color" Option did nothing but then I touched Strenght and woooosh... Also made the rendering much better (no banding in Normal mapped faces) $\endgroup$ – Carsten Wartmann Aug 7 '19 at 10:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.