2
$\begingroup$

I'm having trouble finding an answer to this, as all my searches come up with people suggesting ways to make a camera shudder effect!

My problem is that in Blender Game mode, when I switch to camera view and play the game, the background outside of the camera view jitters/ flickers very fast.

If I start the game in user/ortho view, it doesn't happen, and when I move to the next level, the camera view is perfect. It's only when I start the game in camera view.

Does anyone have any suggestions? Is this a known problem?

Thanks!

$\endgroup$
  • $\begingroup$ This sounds strange. Does that always happen (with any file)? If not can you post a demo file? $\endgroup$ – Monster Sep 26 '17 at 7:33
  • $\begingroup$ Thanks for your reply. Yes, it happens with any file. Here is a link to a screen grab showing the problem. In User view it doesn't happen if I hit P. In camera view it happens if I hit P and when I hit embedded player button. The player button also goes crazy in both views. See for yourself here: link $\endgroup$ – RexTheRunt Sep 26 '17 at 12:51
  • $\begingroup$ By the way, I meant to include this information: I'm on version 2.79 on Mac OS 10.12.6. Also just tested again and it does keep on happening on subsequent levels. $\endgroup$ – RexTheRunt Sep 26 '17 at 13:02
1
$\begingroup$

This seems to be a mac issue - the solution is to change the Window Draw Method in User Preferences/System - from no multisample to Multisample 2 at least. multisample setting

$\endgroup$

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.